Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Jul 2017

    Rampage IV Formula refuses to post

    Hello all,

    I was surfing the web on my PC the other day as the screen turned completely black and the computer reset itself. After that it has been refusing to boot. All fans turn on except my graphics card, but its light comes on and the problem replicates itself without a graphics card as well, so I am pretty sure it is not causing the issue. The red CPU led on the motherboard (Rampage IV Formula) for diagnostics comes up and does not go away, and the LED numbers which turn on with every POST stay off, so I think the problem lies within something pre-POST. I tried replacing RAM and reseating the CPU with no help. At this point I think the problem is within either the CPU or the motherboard but I cannot be sure. Any suggestions?

    My specs are:
    Intel Xeon E5-1650
    Rampage IV Formula
    2x8GB Crucial Ballistix Tactical
    Sandisk Plus 240gb SSD
    XFX RX480
    Corsair 750W PSU


  2. #2
    ASUS HQ Service Rep Array
    Join Date
    May 2016

    The Red light , it looks like Xeon E5-1650 problem, can you try install other CPUs e,g Core i7 series
    or just rry update the BIOS / cleaning CMOS

  3. #3
    ROG Guru: White Belt Array Marcello.S PC Specs
    Marcello.S PC Specs
    MotherboardGigabyte Aorus Master Z390
    ProcessorIntel Core i9-9900K
    Memory (part number)Kingston HyperX Savage 3000 CL15 2x8 GB
    Graphics Card #1EVGA nVidia GTX 1080 Ti FTW3 Gaming
    MonitorASUS VG248QE w/ nVidia 3D Vision 2
    Storage #1SAMSUNG SSD 840 PRO 256 GB + 512 GB
    Storage #2Samsung nvme 970 Pro 512 GB
    CPU CoolerCORSAIR H115i PRO
    CaseCooler Master MasterCase MC500M
    Power SupplyCORSAIR RM-750x w/ Premium PSU Cable Kit
    Keyboard Corsair K95 RGB Platinum
    Mouse Logitech G502 Proteus Spectrum
    Headset Corsair HS70
    Mouse Pad ThunderX3 TMP30
    Headset/Speakers Bose Sound Link Mini
    Accessory #1 APC Back-UPS 900
    Marcello.S's Avatar
    Join Date
    Apr 2016

    A temporary overvoltage could have cause the issue. Builzoid raised the vCore of an Athlon up to 1.95 Volt and the PC suddenly shut down and refused to boot either post after that.

  4. #4
    New ROGer Array
    Join Date
    Jul 2017

    Well, I am unable to mount another CPU to my motherboard but I tried my own CPU with another motherboard, and it booted up fine, so I am thinking the problem is with the mobo. Tried clearing CMOS and the USB Flashback, it flashed the BIOS successfully but did not help. Any other suggestions?

    Thanks in advance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts