Results 1 to 8 of 8
  1. #1
    New ROGer Array SleiderVonNarwafle PC Specs
    SleiderVonNarwafle PC Specs
    MotherboardG20AJ
    Processori5-4460@3.20GHZ
    Graphics Card #1GTX750ti
    SleiderVonNarwafle's Avatar
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    4

    Bizarre Screen Freezing/Twitching When Playing Any Game

    I've recently been running into random screen freezing and frame rate loss issues when playing games that I can normally, run perfectly well.
    I'll be playing, say, Skyrim for example, and I'm getting silky smooth 60fps with the occasional stutter here and there, and then suddenly, out of nowhere, I get bad fps drop and then my screen freezes and twitches strangely for around 15-30 seconds, then to return to normal for the next minute or so, only to happen again.
    This has also happened in these games: Dark Souls 1, War Thunder, FalloutNV, and STALKER SoC.
    My hardware can certainly handle all of these games, here are my specs:
    MB: G20AJ
    GPU:GTX 750ti
    CPU: i5-4460@3.20GHZ
    RAM: 8GB
    I've troubleshooted for malware, heat issues, mod issues, but nothing.
    Now, a disclaimer, I am still relatively new to the ins and outs of what can go wrong with a computer and its many components, and what the problems that are shown through my gameplay are indicative of in many circumstances, including this one. So, if you believe you could help me with my issue, I would very much appreciate it

  2. #2
    ex-ASUS Employee Array Eleiyas PC Specs
    Eleiyas PC Specs
    MotherboardASUS 970 PRO GAMING/AURA
    ProcessorAMD FX 8370
    Memory (part number)Corsair 8GB XMS3 PC3-12800 1600MHz DDR3
    Graphics Card #1XFX AMD Radeon HD 6950 - 2G
    MonitorLG Flatron E2240T 21.5'' 1080p Monitor
    Storage #1Samsung 1TB 7200RPM 32MB
    Storage #2Seagate Barracuda 2TB 7200RPM 64MB 6GB/s
    CPU CoolerAMD Wraith Cooler
    CaseNZXT Lexa S
    Power SupplyCorsair CX600 600W (Bronze)
    Keyboard Logitech Wireless AZERTY
    Mouse Microsoft Wireless
    Headset Evil Witchcraft II Gaming Headset (Black/Red)
    Mouse Pad Wild Wolf Hunter
    Headset/Speakers 4Gamers 2.1 Sound-System
    OS Windows 10 Professional - Creator's
    Network RouterZiggo

    Join Date
    Mar 2017
    Reputation
    25
    Posts
    375

    The first thing that pops into my head (and it will most others), is that something is wrong with your graphics card and/or the drivers.

    have you installed the latest drivers for your card?

  3. #3
    New ROGer Array SleiderVonNarwafle PC Specs
    SleiderVonNarwafle PC Specs
    MotherboardG20AJ
    Processori5-4460@3.20GHZ
    Graphics Card #1GTX750ti
    SleiderVonNarwafle's Avatar
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    4

    Quote Originally Posted by Eleiyas@ASUS View Post
    The first thing that pops into my head (and it will most others), is that something is wrong with your graphics card and/or the drivers.

    have you installed the latest drivers for your card?
    My graphics card is actually no more than a few months old, and yes, I have the latest drivers.

  4. #4
    ex-ASUS Employee Array Eleiyas PC Specs
    Eleiyas PC Specs
    MotherboardASUS 970 PRO GAMING/AURA
    ProcessorAMD FX 8370
    Memory (part number)Corsair 8GB XMS3 PC3-12800 1600MHz DDR3
    Graphics Card #1XFX AMD Radeon HD 6950 - 2G
    MonitorLG Flatron E2240T 21.5'' 1080p Monitor
    Storage #1Samsung 1TB 7200RPM 32MB
    Storage #2Seagate Barracuda 2TB 7200RPM 64MB 6GB/s
    CPU CoolerAMD Wraith Cooler
    CaseNZXT Lexa S
    Power SupplyCorsair CX600 600W (Bronze)
    Keyboard Logitech Wireless AZERTY
    Mouse Microsoft Wireless
    Headset Evil Witchcraft II Gaming Headset (Black/Red)
    Mouse Pad Wild Wolf Hunter
    Headset/Speakers 4Gamers 2.1 Sound-System
    OS Windows 10 Professional - Creator's
    Network RouterZiggo

    Join Date
    Mar 2017
    Reputation
    25
    Posts
    375

    if you're sure the graphics are ok - try running memtest on your RAM.
    Maybe you have a faulty RAM stick.

  5. #5
    New ROGer Array SleiderVonNarwafle PC Specs
    SleiderVonNarwafle PC Specs
    MotherboardG20AJ
    Processori5-4460@3.20GHZ
    Graphics Card #1GTX750ti
    SleiderVonNarwafle's Avatar
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    4

    Hm.. Ill try it, but doesnt faulty ram usually mean a lot of crashing? Because I haven't been getting any of that :/

  6. #6
    ROG Guru: Black Belt Array Korth PC Specs
    Korth PC Specs
    MotherboardASUS X99 R5E (BIOS2101/1902)
    ProcessorHaswell-EP E5-1680-3 SR20H/R2 (4.4GHz)
    Memory (part number)Vengeance LPX 4x8GB SS DDR4-3000 (CMK32GX4M4C3000C15)
    Graphics Card #1NVIDIA Quadro GP100GL/16GB, 16xPCIe3, NVLink1 (SLI-HB)
    Graphics Card #2NVIDIA Quadro GP100GL/16GB, 16xPCIe3, NVLink1 (SLI-HB)
    Sound CardJDS Labs O2+ODAC (RevB), USB2 UAC1
    MonitorASUS PG278Q
    Storage #1Samsung 850 PRO 512GB SSDs, 4xSATA3 RAID0
    Storage #2Comay BladeDrive E28 3200GB SSD, 8xPCIe2
    CPU CoolerRaijintek NEMESIS/TISIS, AS5, 2xNH-A14
    CaseObsidian 750D (original), 6xNH-A14
    Power SupplyZalman/FSP ZM1250 Platinum
    Headset Pilot P51 PTT *modded*
    OS Arch, Gentoo, Win7x64, Win10x64
    Network RouterActiontec T3200M VDSL2 Gateway
    Accessory #1 TP-Link AC1900 Archer T9E, 1xPCIe
    Accessory #2 ASUS/Infineon SLB9635 TPM (TT1.2/FW3.19)
    Accessory #3 ASUS OC Panel I (FW0501)
    Korth's Avatar
    Join Date
    Mar 2015
    Reputation
    152
    Posts
    2,718

    I'd check the DisplayPort cable. And does your monitor get really hot?

  7. #7
    New ROGer Array SleiderVonNarwafle PC Specs
    SleiderVonNarwafle PC Specs
    MotherboardG20AJ
    Processori5-4460@3.20GHZ
    Graphics Card #1GTX750ti
    SleiderVonNarwafle's Avatar
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    4

    cerro pattison

    Quote Originally Posted by Korth View Post
    I'd check the DisplayPort cable. And does your monitor get really hot?
    Well, it seems as though my initial freezing problem was due to display driver crashes, which I fixed through editing some windows settings.
    However, I'm now faced with new fps drop issues I've not dealt with before. Nothing super serious, but it's very annoying how my fps drops down to 35-40 on games that I was able to run at 60+ in the past.. Especially older games like M&B warband.
    I've noted that my gpu usage shoots up to 90-100% usage whilst cpu and memory stay well below half, is this normal?

  8. #8
    ROG Member Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    6

    I had few seconds freezing randomly on my ROG with Core i7-9700. I searched many discussions and did many things but nothing could fix it until it became worse and I noticed that the cause is my Seagate 3TB hard disk. I replaced the Hard Disk with new 4TB. It solved this randomly few seconds freezing completely.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •