Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    3

    2 pumps connected to single W_PUMP+ PWM header?

    So, the Crosshair VI Hero only has a single W_PUMP+ PWM header, but I have two EK-XTOP Revo D5 PWM pumps. It says the W_PUMP+ header has a max power of 36 watts, but each pump has a power consumption of 23 watts, or 46 watts together, so 10 watts higher than what the header is supposedly capable of. Should I be worried? Is it possible to damage the board by doing this? And will my pumps run at full power?

  2. #2
    ROG Guru: White Belt Array
    Join Date
    Jun 2013
    Reputation
    16
    Posts
    79

    Quote Originally Posted by Speaker1264 View Post
    So, the Crosshair VI Hero only has a single W_PUMP+ PWM header, but I have two EK-XTOP Revo D5 PWM pumps. It says the W_PUMP+ header has a max power of 36 watts, but each pump has a power consumption of 23 watts, or 46 watts together, so 10 watts higher than what the header is supposedly capable of. Should I be worried? Is it possible to damage the board by doing this? And will my pumps run at full power?
    Certainly
    There may be a problem for the motherboard to boot, damage the connector or cause the pumps to not work 100%.
    Try to connect one of the pumps to a fan connector with optional PWM ( note de voltage/watts limits )

    I use this external controller from KOOLANCE and I find it much better than any internal controller

    http://koolance.com/ctr-cd1224-pump-...r-with-display

    Click image for larger version. 

Name:	Capturar444.JPG 
Views:	11 
Size:	17.2 KB 
ID:	66171

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •