Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Jul 2017

    Bsod after G20 bios update

    Long story short, I have a G20 with Win8. Wanted to upgrade to Win10 but needed bios update from Asus. Downloaded it and rebooted with new bios .cap file and got bsod with clock_watchdog_timeout error message.

    There was no way to get out of that screen so I hit power button to shut off pc. When I turned it back on, pc doesn't boot, at all. Usually when it turns on, fans run for about 1 second and computer boots up. Now when I turn it on, fans start and run non-stop but pc does nothing. No screens whatsoever.

    Tried different methods to try and reset bios. Help power button for 30sec with power plug off, also opened up case and tried to reset CMOS by switching CTRLC connector and by taking CMOS battery out for a few minutes. Nothing.

    I'm out of options. Any suggestions? Keep in mind I cannot access ANY menus, as pc simply won't boot up at all.

    Sent from my SM-G928T using Tapatalk

  2. #2
    ex-ASUS Employee Array Eleiyas PC Specs
    Eleiyas PC Specs
    MotherboardASUS 970 PRO GAMING/AURA
    ProcessorAMD FX 8370
    Memory (part number)Corsair 8GB XMS3 PC3-12800 1600MHz DDR3
    Graphics Card #1XFX AMD Radeon HD 6950 - 2G
    MonitorLG Flatron E2240T 21.5'' 1080p Monitor
    Storage #1Samsung 1TB 7200RPM 32MB
    Storage #2Seagate Barracuda 2TB 7200RPM 64MB 6GB/s
    CPU CoolerAMD Wraith Cooler
    CaseNZXT Lexa S
    Power SupplyCorsair CX600 600W (Bronze)
    Keyboard Logitech Wireless AZERTY
    Mouse Microsoft Wireless
    Headset Evil Witchcraft II Gaming Headset (Black/Red)
    Mouse Pad Wild Wolf Hunter
    Headset/Speakers 4Gamers 2.1 Sound-System
    OS Windows 10 Professional - Creator's
    Network RouterZiggo

    Join Date
    Mar 2017

    Seeing as you cannot access your PC at all, even after having attempted a CMOS reset and a hard-reset, I would recommend getting in contact with your local ASUS support.

  3. #3
    ROG Guru: Orange Belt Array chilinmichael's Avatar
    Join Date
    Dec 2012

    Yep, it's bricked. The way Asus has bios updates delivered to this PC (unchecked through Windows, unlike a Dell where it writes then applies after reboot) is dangerous and dated. Make sure when you send it in to note to ensure the Bios is fully updated before it's returned (they'll likely swap out the motherboard)
    Asus G20CB - Core i7 6700, Nvidia GTX980, 16GB Ram, 256GB SK Hynix SSD, 1TB Samsung SSD.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts