Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17
  1. #11
    ROG Guru: Black Belt Array toronto699 PC Specs
    toronto699 PC Specs
    Laptop (Model)G752-VY-DH78K , G751-JYDH72X
    MotherboardRog Tytan G30AB
    Processori7-4770K
    Memory (part number)32GB
    Graphics Card #1Asus Gold20th GTX980Ti
    Sound CardDell X-Fi Audigy SoundBlaster
    Monitor3 Acer K272HL
    Storage #1118 GB/OS
    Storage #22.72 TB
    CPU CoolerIntegrated Liquid-Cooled CPU
    CaseG30AB
    Power SupplyAsus 700 Watt
    Keyboard Razer BlackWidow Ultimate
    Mouse Razer Diamond Back
    Headset Sony Studio Professional , Razer Seiren Mic
    Mouse Pad Razer FireFly
    Headset/Speakers Logittech 5.1 Z-5500
    OS W 10
    Network RouterSagemon Fast 5250 Hub 2000

    Join Date
    Aug 2014
    Reputation
    74
    Posts
    2,408

    I did a search of the forums the updater 1.0.3 seems to have some issue that has not been resolved there are more posts like the one below with no resolve , My G752VY has the 1.0.3 updater but I never installed it
    https://rog.asus.com/forum/showthrea...o+gear+updater

  2. #12
    ROG Member Array
    Join Date
    Jul 2017
    Reputation
    10
    Posts
    5

    Hello, I also have a question regarding the ROG Gaming center, and this seems to be the right thread. I too bought a G752vs model:

    https://www.dateks.lv/en/cenas/porta...0_home_eng_kbd

    Turbo Gear version: 1.0.5.

    The problem is that GPU usage and voltage is not being displayed in the Gaming Center (always 0). What should I try to fix this, and how does one update the gaming center?

  3. #13
    ROG Guru: White Belt Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    95

    Hi KRenga.

    First I would try uninstalling the ROG Gaming Center and rebooting, then try installing ROG Gaming Center again, then reboot. Hopefully that will fix your issue.

    If it doesn't help, then you might want to try either using system restore in Windows to restore it to a date where the ROG Gaming Center worked properly or restoring your laptop to factory defaults.

  4. #14
    ROG Member Array
    Join Date
    Aug 2017
    Reputation
    10
    Posts
    9

    I will probably wait for some fix or release of a new version, expect for that everything is fine!

  5. #15
    ROG Member Array
    Join Date
    Jul 2017
    Reputation
    10
    Posts
    5

    Thanks for the suggestion Cool Dude, but unfortunately reinstalling didn't help. As for the other suggestion - it's been like that since I bought it 3 weeks ago. How does one check for updates for the Gaming Center?
    Last edited by KRenga; 08-09-2017 at 12:24 PM.

  6. #16
    ROG Guru: White Belt Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    95

    Hello!

    Sorry to hear reinstalling didn't help.

    One would go to Asus's webpage under support, search for one's model, and then you will see all the drivers\software available for your model.

    https://www.asus.com/ca-en/support/

  7. #17
    ROG Member Array
    Join Date
    Jul 2017
    Reputation
    10
    Posts
    5

    Ah, right. Thank you!

Page 2 of 2 FirstFirst 1 2

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •