Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1
    ROG Member Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    11

    ROG 751 JY not recogizing Samsumg M.2 960 PRO 2TB SSD

    Hi, subject says it all.
    The laptop boots to the BIOS (211) screen & does not show the new 2TB PCIE M.2 SSD drive.
    It is a 3.0 x4 interface, so it should see it & work.
    I tried enabling & disabling fast boot & the same with Launch CSM, still, nothing.
    I plugged in my USB stick & it goes through what looks like the backtracker process copying to the hard drive, so it says, yet when it says remove USB & reboot, it comes right back to the BIOS screen.

    Any ideas?

  2. #2
    nb Array NeoBeum PC Specs
    NeoBeum PC Specs
    Laptop (Model)G751JY
    MotherboardHM87
    Processori7-4860HQ
    Memory (part number)32Gb Kingston Hyper-X
    Graphics Card #1nVidia GTX980M
    Storage #1Samsung 950 Pro NVMe 256 Gb, Samsung 850 Pro 512 Gb
    Storage #22 TB HGST 7KRPM RAID0
    OS Windows Server 2016 Datacenter
    NeoBeum's Avatar
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    175

    Quote Originally Posted by ButchN View Post
    ...
    Hi, the BIOS doesn't naively support NVMe. Also, with Secure Boot turned on. The 960s will have a harder time getting windows to install on them from a clean install on them because ss didn't sign the 2.2 drivers properly for boot critical. The 1.4.6 drivers are, but they weren't 960 WHQL. Unless someone else knows Samsung Consumer nvme driver 2.0 and above are needed for 960s
    <img src="eckyeckypoobah.gif" onerror="alert('An error occurred loading the image.')" />

  3. #3
    ROG Guru: Brown Belt Array Darnassus PC Specs
    Darnassus PC Specs
    Laptop (Model)G752VS -=-=- G750JX
    MotherboardASUSTeK COMPUTER INC. G752VS (U3E1) -=-=- ASUSTeK COMPUTER INC. G750JX (SOCKET 0)
    Processori7 6700HQ @ 2.60GHz -=-=- i7-4700HQ CPU @ 2.40GHz - 3.40GHz
    Memory (part number)2x16gb (M471A2K43BB1-CRC) -=-=- 2x8gb (HMT41GS6AFR8A-PB)
    Graphics Card #1GTX 1070 (8GB) -=-=- GTX 770M (3GB)
    Sound CardRealtek High Definition Audio / NVIDIA High Definition Audio
    MonitorGSync IPS 75HZ -=-=- Chi Mei 60Hz (Overclocked to 85Hz)
    Storage #1Samsung SSD 960 EVO 250GB x2 -=-=- LITEONIT LCS-256M6S
    Storage #2HGST HTS721010A9E630 -=-=- ST1000LM024 HN-M101MBB
    CPU CoolerStock -=-=- Stock
    CaseStock -=-=- Stock
    Power SupplyStock -=-=- Stock
    Keyboard Stock -=-=- Stock
    Mouse Razer Naga Epic 1st Generation
    Headset SPH 2500
    Mouse Pad Razer Goliathus
    OS Winblows 10 Pro -=-=- Winblows 8.1 Pro
    Network RouterCG3000v2
    Darnassus's Avatar
    Join Date
    Dec 2013
    Reputation
    61
    Posts
    1,634

    ... is it just the BIOS that cannot see the NVMe's? You can still boot to OS, correct? :f
    Gosh Blue Lady.. ❤

    JOIN THE ASUS T-SHOOT DISCORD <-- Clicky!

  4. #4
    ROG Guru: Gold Belt Array Clintlgm PC Specs
    Clintlgm PC Specs
    Laptop (Model)Asus G752VY DH72
    MotherboardAsus Z97 Pro WiFi and /Z97 Pro A
    ProcessorI7 4790K
    Storage #1512 GB M.2 Samsung 960 Pro
    Storage #21 TB Samsun 850 Pro
    CaseCool Master Haf
    OS Win 8.1 Pro and Win 10 Pro
    Clintlgm's Avatar
    Join Date
    Jul 2012
    Reputation
    99
    Posts
    4,097

    My G752VY runs fine on RST drivers no Samsung driver needed?
    G752VY-DH72 Win 10 Pro
    512 GB M.2 Samsung 960 Pro
    1 TB Samsung 850 pro 2.5 format
    980m GTX 4 GB
    32GB DDR 4 Standard RAM

    Z97 PRO WiFi I7 4790K
    Windows 10 Pro
    Z97 -A
    Windows 10 Pro

  5. #5
    nb Array NeoBeum PC Specs
    NeoBeum PC Specs
    Laptop (Model)G751JY
    MotherboardHM87
    Processori7-4860HQ
    Memory (part number)32Gb Kingston Hyper-X
    Graphics Card #1nVidia GTX980M
    Storage #1Samsung 950 Pro NVMe 256 Gb, Samsung 850 Pro 512 Gb
    Storage #22 TB HGST 7KRPM RAID0
    OS Windows Server 2016 Datacenter
    NeoBeum's Avatar
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    175

    I was implying having the laptop be able to see and give the nvme drive its own menu in BIOS.
    You can still get it working, its just a few tweaks.
    but the seperate bios menu doesn't appear for the 751.
    im testing the difference driver signing has for windows major version update and secure boot
    I have a feeling this is whats causing some problems during updates


    edit: ah crap.. just realised I need to get installation images for 1607 to use with 1703.. I might use 1511...
    Last edited by NeoBeum; 08-20-2017 at 06:39 PM.
    <img src="eckyeckypoobah.gif" onerror="alert('An error occurred loading the image.')" />

  6. #6
    ROG Member Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    11

    The laptop boots to the BIOS with the 960 in its slot.
    When I put the boot drive in slot 2, then the laptop boots, & in disk manager sees the drive.
    But I can't seem to get the this much faster & better drive to work as the boot.

    And Acronis doesn't seem to want to clone to this drive.
    help please!

  7. #7
    nb Array NeoBeum PC Specs
    NeoBeum PC Specs
    Laptop (Model)G751JY
    MotherboardHM87
    Processori7-4860HQ
    Memory (part number)32Gb Kingston Hyper-X
    Graphics Card #1nVidia GTX980M
    Storage #1Samsung 950 Pro NVMe 256 Gb, Samsung 850 Pro 512 Gb
    Storage #22 TB HGST 7KRPM RAID0
    OS Windows Server 2016 Datacenter
    NeoBeum's Avatar
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    175

    Click image for larger version. 

Name:	WHQL.PNG 
Views:	8 
Size:	151.3 KB 
ID:	66819

    https://rog.asus.com/forum/showthrea...cal-Windows-10


    The 960s need Samsung Driver 2.0+ to be able to operate in Recovery Environment. I deleted my version of 2.0, and only have 2.2. You might be able to use 1.4.7 (Ask one of the other guys that has a 960. I only have a 950)
    Last edited by NeoBeum; 08-22-2017 at 01:38 PM.
    <img src="eckyeckypoobah.gif" onerror="alert('An error occurred loading the image.')" />

  8. #8
    ROG Member Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    11

    Thanks, but while am somewhat pc literate, where would this driver be installed, to the SSD that does not boot to begin with?
    Would I load the SSD as teh 2nd drive, then install the driver?

    As it stands, & I have win 8.1, the BIOS is what is not recognizing the new SSD.

    This confuses me.

  9. #9
    ROG Guru: Orange Belt Array Julskey's Avatar
    Join Date
    Feb 2013
    Reputation
    18
    Posts
    387

    I think the G751 does not support the NVME m.2. I think you need the AHCI version?

  10. #10
    nb Array NeoBeum PC Specs
    NeoBeum PC Specs
    Laptop (Model)G751JY
    MotherboardHM87
    Processori7-4860HQ
    Memory (part number)32Gb Kingston Hyper-X
    Graphics Card #1nVidia GTX980M
    Storage #1Samsung 950 Pro NVMe 256 Gb, Samsung 850 Pro 512 Gb
    Storage #22 TB HGST 7KRPM RAID0
    OS Windows Server 2016 Datacenter
    NeoBeum's Avatar
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    175

    Not in a native sense, but you can get it to boot by loading the nvme drivers in the pre installation environment and recovery environment.
    Ahci in bios is required for the moment, and disabling secure boot will help.

    I'll have a solution ready for the g751 next week that users can compile themselves or use a prebuilt template on my github
    <img src="eckyeckypoobah.gif" onerror="alert('An error occurred loading the image.')" />

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •