Page 7 of 13 FirstFirst ... 5 6 7 8 9 ... LastLast
Results 61 to 70 of 130
  1. #61
    ROG Enthusiast Array
    Join Date
    Dec 2013
    Reputation
    11
    Posts
    45

    [QUOTE=XtraArrow;706140]
    Quote Originally Posted by HeavyHemi View Post

    Still though, i don't see how you can compare simulated to the true 7.1. if you're that bothered, buy a pair of decent studio headphones or better yet get your headset replaced as mine on 7.1 supported games sound a lot better now after the beta driver. By the way, i don't use any modified setup whilst playing 7.1 supported content, ONLY stereo content in which i then enable the sub to handle frequencies lower than 60hz.

    EDIT: after viewing your original Dolby test file, i loaded it up and listened to the guy on the channels. The only reason why they lack detail as there NOT using the LFE channel and if i recall they are ONLY 20mm drivers so they're not going to reproduce the lows as good as the center or fronts are.

    Bothered? I like how they sound in stereo. I can't believe you're yammering at me to 'buy hew headphones'...sheesh. They sound better in stereo than the TIamats by far. The issue is how bad surround is in games. Maybe you think it's better. Compared to the Tiamat used with the Xonar Phoebus it's bad. Some games it's tolerable Batman AC is okay, Bioshock is okay. Not a single game is good, mostly due to poor vocal localization and side/rear channel drops outs pretty much what everyone else is complaining about.

  2. #62
    ROG Member Array
    Join Date
    Jul 2017
    Reputation
    10
    Posts
    6

    Just want to tell ROG-staff that the support-site is not working with Firefox (atleast not for me)

    If you want to download anything from the supportpage, it just open up a new tab with random code, in Firefox.

    Chrome works, but not Firefox.



    https://www.asus.com/us/Headphones-H...Desk_Download/

  3. #63
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by Bruc3 View Post
    Just want to tell ROG-staff that the support-site is not working with Firefox (atleast not for me)

    If you want to download anything from the supportpage, it just open up a new tab with random code, in Firefox.

    Chrome works, but not Firefox.



    https://www.asus.com/us/Headphones-H...Desk_Download/
    Thanks for reporting the issue, we'll have the team look at it.

  4. #64
    ROG Member Array
    Join Date
    Sep 2016
    Reputation
    10
    Posts
    17

    Quote Originally Posted by MasterC@ASUS View Post
    * *Thanks for the feedback, I'll discuss this with the audio team.
    Hi folks.

    I just purchased Centurions on Monday and after much tuning, I was dismayed to discover the Sub Channel not being used at all.

    I contacted the Sound Developer at iRacing and discussed it with him directly and he came back to me rather amazed to see how the ROG doesn’t have a LF crossover, exactly as you guys are discussing above! All he could suggest was that I post in this thread and hope that ASUS come up with a solution soon.

    I think this should be a priority, especially as this is a high end/high priced headset. In all other aspects I am very pleased with them, but this seems like a massive oversight.

  5. #65
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by quattroboy View Post
    Hi folks.

    I just purchased Centurions on Monday and after much tuning, I was dismayed to discover the Sub Channel not being used at all.

    I contacted the Sound Developer at iRacing and discussed it with him directly and he came back to me rather amazed to see how the ROG doesn’t have a LF crossover, exactly as you guys are discussing above! All he could suggest was that I post in this thread and hope that ASUS come up with a solution soon.

    I think this should be a priority, especially as this is a high end/high priced headset. In all other aspects I am very pleased with them, but this seems like a massive oversight.
    If the subwoofer channel has no signal going into it, then the game or content you are playing doesn't support the 0.1 channel (as in 7.1). If bass is acquired from other channels then the sub channel wouldn't be independent anymore, it will depend on other channels to be active (we would then have to call this Centurion 7.0).

    Please check that the subwoofer channel is indeed working as intended:
    Click image for larger version. 

Name:	7.1 test.JPG 
Views:	37 
Size:	24.9 KB 
ID:	72461

    If you haven't already, try the beta firmware for improved bass:
    https://www.asus.com/us/Headphones-H...221.1511925089

  6. #66
    ROG Enthusiast Array
    Join Date
    Dec 2013
    Reputation
    11
    Posts
    45

    Quote Originally Posted by MasterC@ASUS View Post
    If the subwoofer channel has no signal going into it, then the game or content you are playing doesn't support the 0.1 channel (as in 7.1). If bass is acquired from other channels then the sub channel wouldn't be independent anymore, it will depend on other channels to be active (we would then have to call this Centurion 7.0).

    Please check that the subwoofer channel is indeed working as intended:
    Click image for larger version. 

Name:	7.1 test.JPG 
Views:	37 
Size:	24.9 KB 
ID:	72461

    If you haven't already, try the beta firmware for improved bass:
    https://www.asus.com/us/Headphones-H...221.1511925089
    Honestly, I don't know what your team is doing. There are several popular titles out there, Fallout 4 for example were you cannot miss what is missing in the side and rear audio channels unless nobody on the team has actually worn them. It is impossible to miss on just about every game title whether it's the character voices or weapons, The side and rear become tinny . At this point, given the basic denial of even the engineers acknowledging (come on why are you STILL asking for examples when the ones provided are perfectly OBVIOUS what the problem is). I don't expect a fix. These sound great in stereo ironically enough...they are fundamentally broken in surround in my view.

  7. #67
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by HeavyHemi View Post
    Honestly, I don't know what your team is doing. There are several popular titles out there, Fallout 4 for example were you cannot miss what is missing in the side and rear audio channels unless nobody on the team has actually worn them. It is impossible to miss on just about every game title whether it's the character voices or weapons, The side and rear become tinny . At this point, given the basic denial of even the engineers acknowledging (come on why are you STILL asking for examples when the ones provided are perfectly OBVIOUS what the problem is). I don't expect a fix. These sound great in stereo ironically enough...they are fundamentally broken in surround in my view.
    Since the Centurion was created for gaming, much manual tuning is required to satisfy such a diverse collection of game titles. We still try to make sure we do not stray too far and ruin the surround sound experience when watching movies.

    Please download and test out the videos below if anyone is unsure if there is something wrong with the subwoofer (0.1) channel.
    https://download.dolby.com/us/en/tes...atmos_leaf.mp4
    https://download.dolby.com/us/en/tes...tmos_amaze.mp4

    If we deviate too much when tuning for games, properly-tuned surround sound content such as these will sound unnatural.

    We are and will continue to improve the gaming experience on the Centurion, I will keep everyone up-to-date. Thanks for your feedback.

  8. #68
    ROG Enthusiast Array
    Join Date
    Dec 2013
    Reputation
    11
    Posts
    45

    Quote Originally Posted by MasterC@ASUS View Post
    Since the Centurion was created for gaming, much manual tuning is required to satisfy such a diverse collection of game titles. We still try to make sure we do not stray too far and ruin the surround sound experience when watching movies.

    Please download and test out the videos below if anyone is unsure if there is something wrong with the subwoofer (0.1) channel.
    https://download.dolby.com/us/en/tes...atmos_leaf.mp4
    https://download.dolby.com/us/en/tes...tmos_amaze.mp4

    If we deviate too much when tuning for games, properly-tuned surround sound content such as these will sound unnatural.

    We are and will continue to improve the gaming experience on the Centurion, I will keep everyone up-to-date. Thanks for your feedback.
    https://rog.asus.com/forum/newreply....reply&p=712113

    Sigh...why are you linking to Atmos Dolby ? Are you listening? The STEREO presentation of the headphones is fine. Atmos works fine. SIMULATED surround works fine (which uses just the two drivers). Hardware 7.1 which uses MULTIPLE DRIVERS IN THE HEADSET, does not work properly. That is the issue. Simulated and Atmos should not be affected by the tuning.

  9. #69
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by HeavyHemi View Post
    https://rog.asus.com/forum/newreply....reply&p=712113

    Sigh...why are you linking to Atmos Dolby ? Are you listening? The STEREO presentation of the headphones is fine. Atmos works fine. SIMULATED surround works fine (which uses just the two drivers). Hardware 7.1 which uses MULTIPLE DRIVERS IN THE HEADSET, does not work properly. That is the issue. Simulated and Atmos should not be affected by the tuning.
    Please download the videos first (bottom-right corner), and play the videos with the 7.1 button on the Audio Station enabled. You'll find that the videos are multi-channel, not stereo and not virtual surround. You can check by disabling the front channels via software or the Audio Station.

  10. #70
    ROG Member Array
    Join Date
    Jul 2017
    Reputation
    10
    Posts
    12

    whens the full version come out?

Page 7 of 13 FirstFirst ... 5 6 7 8 9 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •