Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    New ROGer Array
    Join Date
    Sep 2017
    Reputation
    10
    Posts
    6

    Help with G751 screen no display after waking from sleep - solved?

    Hello all, I just gotten an used G751 it has win 10 installed.

    Issue i am having is if I use the "Sleep" mode in window and come back to the laptop later it will power on but display is black. I know the back light is working as i can see the grow. I plugged into a monitor and nothing. only way to fix this is hold the power button down and wait for it to turn off, than press power button again and the display is working again.

    Laptop is clean install, I updated bio to 211. update the video driver. Geforce version 385.41
    I also read the forum link for the G751 I downed the ATK so i can now control the keyboard lights.

    One thing that is weird is that once I turn on the laptop after "sleep" i first thought it was just something to do with the video card. But now i think it could be something else. The keys back lights up red full power, and even if I press the FN + F3 the lights are no longer turning down and off.

    Any suggestions on what I should try next?

    there are not much software on this laptop just Avast Antivirus, Steam, Malwarebytes, and 2 games.

  2. #2
    ROG Guru: Blue Belt Array Gps3dx PC Specs
    Gps3dx PC Specs
    Laptop (Model)Current: G751JT | Retired: G55VW, G51JX
    MotherboardInc M.2 slot
    Storage #1Samsungs EVO 850 128GB
    Storage #21TB HGST Travelstar 7K1000 (HTS721010A9E630)
    CPU CoolerMother Nature & Thermodynamics laws
    Mouse Logitech MX 518
    Headset/Speakers Logitech T6060
    OS Cleaned installed Windows 10 HOME x64
    Accessory #1 Leap Motion

    Join Date
    Feb 2015
    Reputation
    71
    Posts
    773

    Quote Originally Posted by edlu21 View Post
    Hello all, I just gotten an used G751 it has win 10 installed.
    1. disable/close Malwarebytes for the duration of the following fixes ( till after reboot is performed ).

    2. reinstall ATK drivers or upgrade them from asus official download page for your device ( choose win10 files ) - it's a must for the sleep feature to work properly.
    after installation, reboot -> check if ok -> if not helped -> goto 3.

    3. reflash same current BIOS version, using Asus's winflash app + the "/nodata" switch.

    P.S - do that these steps above, any time your windows is being upgraded a major release, e.i from win8->win10, from win10 RTM -> win10 anniversary/ creators update, from win10 anniversary -> win10 creators update.

  3. #3
    New ROGer Array
    Join Date
    Sep 2017
    Reputation
    10
    Posts
    6

    Quote Originally Posted by Gps3dx View Post
    1. disable/close Malwarebytes for the duration of the following fixes ( till after reboot is performed ).

    2. reinstall ATK drivers or upgrade them from asus official download page for your device ( choose win10 files ) - it's a must for the sleep feature to work properly.
    after installation, reboot -> check if ok -> if not helped -> goto 3.

    3. reflash same current BIOS version, using Asus's winflash app + the "/nodata" switch.

    P.S - do that these steps above, any time your windows is being upgraded a major release, e.i from win8->win10, from win10 RTM -> win10 anniversary/ creators update, from win10 anniversary -> win10 creators update.
    Thanks for the info. I tired to look at the links of drivers in your post and those links are dead for the ATK.
    There is where I downloaded the ATK file. Not sure if there is any newer version.
    https://www.asus.com/us/ROG-Republic...Desk_Download/

  4. #4
    New ROGer Array
    Join Date
    Sep 2017
    Reputation
    10
    Posts
    6

    Quote Originally Posted by edlu21 View Post
    Thanks for the info. I tired to look at the links of drivers in your post and those links are dead for the ATK.
    There is where I downloaded the ATK file. Not sure if there is any newer version.
    https://www.asus.com/us/ROG-Republic...Desk_Download/
    redid the Bio, and update the ATK to 1.0.0055. and same thing blink screen after sleep.

    so my temp fix is to change the power setting so the laptop never goes to sleep when plugged in. Still open to any suggestions.

  5. #5
    ROG Guru: Brown Belt Array Darnassus PC Specs
    Darnassus PC Specs
    Laptop (Model)G752VS -=-=- G750JX
    MotherboardASUSTeK COMPUTER INC. G752VS (U3E1) -=-=- ASUSTeK COMPUTER INC. G750JX (SOCKET 0)
    Processori7 6700HQ @ 2.60GHz -=-=- i7-4700HQ CPU @ 2.40GHz - 3.40GHz
    Memory (part number)2x16gb (M471A2K43BB1-CRC) -=-=- 2x8gb (HMT41GS6AFR8A-PB)
    Graphics Card #1GTX 1070 (8GB) -=-=- GTX 770M (3GB)
    Sound CardRealtek High Definition Audio / NVIDIA High Definition Audio
    MonitorGSync IPS 75HZ -=-=- Chi Mei 60Hz (Overclocked to 85Hz)
    Storage #1Samsung SSD 960 EVO 250GB x2 -=-=- LITEONIT LCS-256M6S
    Storage #2HGST HTS721010A9E630 -=-=- ST1000LM024 HN-M101MBB
    CPU CoolerStock -=-=- Stock
    CaseStock -=-=- Stock
    Power SupplyStock -=-=- Stock
    Keyboard Stock -=-=- Stock
    Mouse Razer Naga Epic 1st Generation
    Headset SPH 2500
    Mouse Pad Razer Goliathus
    OS Winblows 10 Pro -=-=- Winblows 8.1 Pro
    Network RouterCG3000v2
    Darnassus's Avatar
    Join Date
    Dec 2013
    Reputation
    61
    Posts
    1,644

    Never use Sleep. It's a problem with Windows on nearly every computer and I suppose, a quick solution if you need to move to another location when using a laptop yet don't want to lose work.

    Things just don't run properly after resuming from Sleep, it's like refreezing fast food, then having it later. It's just not nice anymore.

    Either shutdown or allow the computer to continuously run with lid closed with 'Do nothing' option selected.

    Hibernate I am unsure of though I assume it's better than Sleep as its method of halting the data and writes it to the disk, then recalls it. While Sleep keeps it all in Ram.


    Trust me using Sleep is a bad habit, it should only be used as a temporary solution when moving from A to B.

    Definitely never use Sleep if you're going to Sleep too. ;d



    More focused on your issue, your problem would possibly be the Display Driver is getting stuck when resuming Windows. A solution that pops into my head is disabling Quick Boot from your Battery Configuration page.
    Last edited by Darnassus; 09-26-2017 at 08:32 AM.
    Gosh Blue Lady.. ❤

    JOIN THE ASUS T-SHOOT DISCORD <-- Clicky!

  6. #6
    ROG Guru: Gold Belt Array Clintlgm PC Specs
    Clintlgm PC Specs
    Laptop (Model)Asus G752VY DH72
    MotherboardAsus Z97 Pro WiFi and /Z97 Pro A
    ProcessorI7 4790K
    Storage #1512 GB M.2 Samsung 960 Pro
    Storage #21 TB Samsun 850 Pro
    CaseCool Master Haf
    OS Win 8.1 Pro and Win 10 Pro
    Clintlgm's Avatar
    Join Date
    Jul 2012
    Reputation
    105
    Posts
    4,121

    I agree with the Blue lady, Sleep is just a hassle on all computers for me. I disable it, I disable fast start up in windows and fast boot in the BIOS. from the beginning windows has had issues restarting with everything working correctly.
    With the SSD were running to day its just as fast to shut down and restart. or just leave your computers running which is what I do mostly.
    G752VY-DH72 Win 10 Pro
    512 GB M.2 Samsung 960 Pro
    1 TB Samsung 850 pro 2.5 format
    980m GTX 4 GB
    32GB DDR 4 Standard RAM

    Z97 PRO WiFi I7 4790K
    Windows 10 Pro
    Z97 -A
    Windows 10 Pro

  7. #7
    New ROGer Array Internetpilot PC Specs
    Internetpilot PC Specs
    Laptop (Model)Asus ROG G751JT (x5)
    MotherboardAsus Z87-A DDR3 1600 LGA 1150
    ProcessorIntel Core i7-4770 3.4 GHZ LGA 1150 8 MB Cache
    Memory (part number)Patriot 16GB Viper III DDR3 1600MHz Black Mamba Heatsink
    Graphics Card #1Gigabyte GeForce GTX 660 OC 2GB
    Storage #1Seagate 2TB BarraCuda (x2 - separate OS and data drives)
    Storage #2Seagate 2TB BarraCuda (x2 for backup)
    CaseCorsair Carbide Series Black 400R Mid Tower
    Power SupplyCorsair Enthusiast TX650 Plus Bronze
    Keyboard Microsoft Wired Keyboard 600
    Mouse Redragon M801 Mammoth 16400 DPI
    Headset Turtle Beach Ear Force Z11
    Mouse Pad Redragon P001 ARCHELON
    OS Windows 10
    Network RouterLinksys AC1750 (x5)
    Internetpilot's Avatar
    Join Date
    Nov 2016
    Reputation
    14
    Posts
    3

    I have a total of five (yep, 5) Asus ROG G751JT laptops, and all of them sleep (and wake up) fine like 99% of the time. The 1% of the time sleep doesn't work, it's just that the laptop has shut down (probably received an update and did a scheduled reboot or something similar). I just checked the power settings on three of them and they're really all over the place with none of them identical to the other, so I don't think it's a settings issue. I've modified the heck out of mine, but my son's laptop seems to have the default settings and then the third laptop has slightly different "default" settings. Just FYI, all of us are running ATK v100050.

    I don't have a SSD in any of the 5, so not using sleep wouldn't be an option for me. The only time I've ever had a problem with a blank screen when coming out of sleep was on my desktop PC and that turned out to indeed be a video card driver problem. I also didn't want to go back to an older version, but it took a couple of newer versions until the problem was resolved. It was also a video card with an Nvidia chipset. Ironically, after I got it resolved that PC is never turned off now (the monitor times out) because it now runs the whole house, but it was still working before I disabled it.

    Have you tried the Fn+F7 trick? I did see where some people can get the screen on by double pressing Fn+F7. With your keyboard lights acting up, it seems like you have a little more of an issue than just the video not coming on, though. Sorry, I'm not of much help, but I wouldn't necessarily just give up on sleep mode. We have over a dozen PCs in the family (both laptops and desktops) and use sleep on all of them without much issue.

    This isn't on a ROG (it's a Toshiba notebook), but the same would apply to your ROG if you wanted to try to change the power settings to see it helps:

    http://www.tomsguide.com/answers/id-...ening-lid.html

  8. #8
    New ROGer Array
    Join Date
    Sep 2017
    Reputation
    10
    Posts
    6

    Thanks to all the suggestions. I removed the "sleep" setting from all the setting, battery or plugged in.

    I am now getting random black screen on cold start up. I been doing little test and I would say it is about 10-20%. Each night I will shut down the laptop, AC is always plugged in. When I come back from work the next day, I will power on, and most of the days it will power on fine. once in a blue moon I will get the black screen. No ROG splash screen, nothing. I know it is doing the start up, I now have an external monitor near by. I just plug in the monitor and use that so I can see the mouse pointer to do restart of the laptop. And bang! upon the restart cycle the laptop screen is back on again. I did try the Fn + F7 few times and nothing. I thought maybe the cable some how is damage when I closed the lid and reopen that caused it. This is not the case as I do not even close the lid anymore after I shut it down for the night. Maybe the video card is going bad? Wait if the video card is bad than it would not output to the monitor at all. Agh....

    This laptop has one HDD, no SDD.

    Video driver is updated via the GeForce Experience and that didn't change anything.
    Last edited by edlu21; 10-06-2017 at 12:52 AM.

  9. #9
    Banned Array JustinThyme PC Specs
    JustinThyme PC Specs
    Laptop (Model)G752VY-DH72
    MotherboardRampage VI Extreme
    ProcessorI9 9940X
    Memory (part number)64GB DDR4 8x8 Corsair Dominator Platinum 3800 MHz @ C17
    Graphics Card #1ASUS Strix 2080Ti O11G @ 2.1GHz
    Graphics Card #2ASUS Strix 2080Ti O11G @ 2.1Ghz
    Graphics Card #3ROG Nvlink
    Graphics Card #4Have to feed animals
    Sound CardExternal Audioengine D1 24 bit 192kbps DAC
    MonitorASUS PG348Q @ 100Hz
    Storage #1Intel 905P 480GB U2 flavor
    Storage #2Samsung 850 EVO 1TB X2 in RAID 0, 960 PRO 1TB DIMM.2_1
    CPU CoolerHeatKiller IV PRO and VRM blocks ,Dual D5 PWM serial, 2X 480, 1X 360 RADS
    CasePhanteks Enthoo Elite 8X LL120 PWM, 3X LL140 PWM, 12 SP120 PWM 1x AF140 PWM
    Power SupplyCorsair AX 1500i
    Keyboard ASUS Claymore
    Mouse ASUS Spatha, Logitech MX Master
    Headset Sennheiser HD 700
    Mouse Pad ASUS ROG Sheath
    Headset/Speakers Audioengine A5+ with SVS SB-1000 Sub
    OS Win10 Pro 1809
    Network RouterNetGear NightHawk X10
    Accessory #1 NetGear Prosafe 10GBe Switch
    Accessory #2 Qnap TVS-682 NAS modded with I7 CPU

    Join Date
    Nov 2013
    Reputation
    144
    Posts
    3,858

    You are one step from a fix. Not only disable the sleep but also disable the fast boot in windows power settings and the BIOs. This is not new, been going on for awhile. When you have fast boot enabled**what’s happening is more like hibernation. Upon power down it dumps the kernel and loaded drivers from the Ram to a file, hiberfil.sys. This not only causes repeatedly large writes to your SSD it also reloads whatever is there with no clean boot. *When you hold the power button down this is dumping that file and forcing a cold boot with a fresh load of the kernel and drivers. If you disable fast boot it never makes that write to hiberfil.sys and you get a fresh load every time.*

  10. #10
    New ROGer Array
    Join Date
    Sep 2017
    Reputation
    10
    Posts
    6

    Thanks everyone for their suggestions. I removed the quick start from windows 10 and so far laptop turns on every night with no problems! Thanks again!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •