Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Sep 2017
    Reputation
    10
    Posts
    3

    Exclamation Maximus Hero VIII / Frontbase or USB problem?

    Hello,

    A year ago, I suffered with problems about my motherboard, I had a Maximus Hero VII.
    The motherboard's issues where; wrong voltages, everything was unstable.
    I send it after a while to the shop where it came from. I got a message a couple week(s) later that it was fixed, and that they where ready to return it to me.
    I don't trusted that motherboard anymore since then. On that moment, I send them a message with the question if it was possible to trade it with a Maximus Hero VIII with the remaining costs. That motherboard is now for my dad's new pc.

    The specs about his pc are:

    Cooler Master V-series 1000W power supply
    i7 7700k cpu
    Corsair Vengeance RGB 32GB
    Corsair Liquid cooling H110i
    Samsung 960 Pro M.2 SSD
    ROG Frontbase
    ROG STRIX GTX 1080 TI O8G graphic card

    A month ago, my dad unpacked the board for the first time. He has it since november 2016. When removed the cover of the cpu socket, there where bend pins.
    After that, I contacted Asus. They received the board, and replaced a new socket, which I saw from the package discription.

    After that, I installed Windows 10 Pro with the drivers. But, when installing the firmware/drivers for the frontbase it gave problems.
    First of all, the connection to the ROG frontbase is placed in the ROG_EXT header, without a q-connector on the moment. Have tried it also with q-connector.
    When pluggin in the usb to the motherboards usb header or the ROG header, Windows gives a message that the USB could not recogniized.
    I have read/tried most of the fixes for the Windows error, or versions of firmware drivers that could help. But no, same error every time.

    The ROG frontbase usb 2.0 in the frontbase itself works, and the display is also normal. When I'm trying to install the firmware, I go to he firmware folder and start the updater. With or without admin privileges. It doesn't work, the application itself says FB not found.

    I thought the frontbase is broken, but then I remember that the USB port is working well as I said.

    I'm curious if someone can help us out.

    Kind regards

  2. #2
    ROG Guru: White Belt Array HeroVIII PC Specs
    HeroVIII PC Specs
    MotherboardASUS Maximus VIII Hero - BIOS 3802
    Processori5 6600K, 3,9 GHZ
    Memory (part number)G.Skill Trident Z 3.200 MHz CL16 4x8GB (F4-3200C16D-16GTZ)
    Graphics Card #1Asus STRIX 1070 Ti Advanced
    Sound CardSabre SS9023P SupremeFX 2015
    MonitorSamsung SMART TV 55" 4K
    Storage #1Samsung SM 961 NVMe 256GB OS
    Storage #2Seagate Barracuda 4TB. ASUS HYPER M.2 X4 MINI CARD with Samsung SM 951 NVMe 256GB Game
    CPU CoolerNoctua NH-U12S
    CaseCorsair 450 D, NZXT Sleeved LED Kit White
    Power SupplyCorsair RM850x ( 2018 ), FURUTECH Evolution Power II, with FURUTECH F1 50 R NCF, F1 E 50 R NCF
    Keyboard Rapoo E2000P
    Mouse Rapoo Optical Mouse
    Headset Sennheiser HD 595, Sony MDR 1 AB
    Headset/Speakers Onkyo TX-NR5009, 7.1 B&W 603 s3 Series and ASW 750
    OS Windows 10 Pro 64Bits UEFI 1909
    Network RouterMitrastar
    Accessory #1 ASUS ROG FRONT BASE - FW 48
    Accessory #2 ASUS PCE-AC56, ASUS DRW-24F1MT
    Accessory #3 Microsoft Xbox One Controller + Wireless Adapter for Windows 10

    Join Date
    Dec 2015
    Reputation
    10
    Posts
    97

    Quote Originally Posted by iixLokoZx View Post
    Hello,

    A year ago, I suffered with problems about my motherboard, I had a Maximus Hero VII.
    The motherboard's issues where; wrong voltages, everything was unstable.
    I send it after a while to the shop where it came from. I got a message a couple week(s) later that it was fixed, and that they where ready to return it to me.
    I don't trusted that motherboard anymore since then. On that moment, I send them a message with the question if it was possible to trade it with a Maximus Hero VIII with the remaining costs. That motherboard is now for my dad's new pc.

    The specs about his pc are:

    Cooler Master V-series 1000W power supply
    i7 7700k cpu
    Corsair Vengeance RGB 32GB
    Corsair Liquid cooling H110i
    Samsung 960 Pro M.2 SSD
    ROG Frontbase
    ROG STRIX GTX 1080 TI O8G graphic card

    A month ago, my dad unpacked the board for the first time. He has it since november 2016. When removed the cover of the cpu socket, there where bend pins.
    After that, I contacted Asus. They received the board, and replaced a new socket, which I saw from the package discription.

    After that, I installed Windows 10 Pro with the drivers. But, when installing the firmware/drivers for the frontbase it gave problems.
    First of all, the connection to the ROG frontbase is placed in the ROG_EXT header, without a q-connector on the moment. Have tried it also with q-connector.
    When pluggin in the usb to the motherboards usb header or the ROG header, Windows gives a message that the USB could not recogniized.
    I have read/tried most of the fixes for the Windows error, or versions of firmware drivers that could help. But no, same error every time.

    The ROG frontbase usb 2.0 in the frontbase itself works, and the display is also normal. When I'm trying to install the firmware, I go to he firmware folder and start the updater. With or without admin privileges. It doesn't work, the application itself says FB not found.

    I thought the frontbase is broken, but then I remember that the USB port is working well as I said.

    I'm curious if someone can help us out.

    Kind regards

    Hi iixLokoZx, it is a hot topic, try to look for the firmware of Rog Front Base in the support page of the motherboard Maximus VIII Hero in particular Version 1.01.17 but dated 2015/10/27 and follow the same steps that you have done to update, you will see as there are several files test with them until the correct solution.
    In this thread you can get up to date a little:

    https://rog.asus.com/forum/showthrea...d=1#post636215

    I hope it helps you.

    Greetings.

  3. #3
    New ROGer Array
    Join Date
    Sep 2017
    Reputation
    10
    Posts
    3

    Talking Solved

    Thanks for your reply,

    At first, when download and launching that driver you menchioned it sayed again that the frontbase not was connected.
    After that, we came to the idea to disconnect the Frontbase from my dad's pc and connect it via USB to my pc.

    I have a Gigabyte G3 Gaming motherboard, plugged the USB in a random port on the board. Updated the Frontbase with the firmware version above, after that again updating with the latest firmware. Disconnected it from my pc, and connected it on his pc. At startup, no errors and no notifications that it would'nt work. Everything just fine. Then ROG Connect plus installed.

    We are glad that everything works now!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •