Results 1 to 1 of 1
  1. #1
    ROG Enthusiast Array
    Join Date
    Aug 2017
    Reputation
    19
    Posts
    71

    G752VL and Samsung EVO 960 SSD - Too easy!

    I've only had my G752VL for a short while and all that time has been spent just getting it setup for use as a MIDI workstation. First was the RAM expansion which was of course uneventful. Now I have completed my migration to booting from an SSD which finally makes this machine useful for its intended purpose. As it turns out this last step went very easily.

    I assumed getting a bootable NVMe SSD setup would be a nightmare after reading the various forums posts on the topic. However it turned out to be VERY easy. Here is what I did for those interested in doing the same thing. It's well worth the effort!


    NOTE: I did all this with a clean Windows 10 Home install - version 1703 (Creators update)
    NOTE: I did a COMPLETE drive image with Macrium Reflect and created boot media and tested the recovery boot before trying any of this. I recommend this to anybody attempting this migration. Always have a backup plan. :-)

    1. I installed the EVO 960 500GB NVMe in the G752. Here is where one rather weird thing happened. When I first powered it up with the NVMe drive mounted, the system started booting normally showing the ROG logo and then instantly did a hard power down. I was a little worried when this happened. However, after this, I powered the machine again and it booted normally. At first Samsung Magician was unable to see the drive even after I created a partition and formatted it in Drive Manager. I even tried installing the latest Samsung NVMe drivers but that failed as well because the drive was not visible to them.

    This was because the BIOS SATA config was set to RAID instead of AHCI. Magician can only see the drive across an AHCI interface. Various posts here make it clear that Samsung Magician is not necessary but I wanted to run it as it detects and updates the SSD firmware if necessary. These things are finicky enough so having the latest firmware on your NVMe is certainly recommended.

    2. In order to get Magician working I rebooted into SAFE mode and during reboot hammered F2 to enter BIOS. Within BIOS I changed the SATA mode from RAID to AHCI and chose "Save & Exit" which continued into SAFE mode. From SAFE mode I went back into the Config tool and unchecked SAFE mode and rebooted again. Quite frankly I'm not sure the SAFE mode step was necessary at all but it was recommended.

    3. Once booted back into normal Windows 10 I ran Samsung Magician which detected the drive and verified that it had the latest firmware. Cool.

    4. Now I ran the Samsung "Data Migration" Tool. This couldn't be easier. Since I hadn't installed anything on the system it was just the OS and though the original drive was 1T, the OS was migrated to the new 500G SSD with lots of space left over. The migration completed without any problems in maybe 15 minutes or so.

    5. At this point the migration was complete leaving two IDENTICAL drives in the machine so I shut the machine down and removed the original 1T Toshiba drive.

    6. After removing the Toshiba I powered up the machine and to my surprise it found the NVMe drive and started booting! It did want to run a quick drive check which literally took about 2 seconds after which it completed a normal boot into the very same Windows 10 environment I had running before! Woohoo!

    7. Since the Toshiba drive still had EFI paritions with GUID's that matched the partitions on the NVMe drive I couldn't mount it on the machine yet. If that is done the system will put the drive "offline" because of a signature collision. To solve that problem I stuck it in a USB dock and removed all the original partitions using DISKPART on another Windows machine. Then I reinstalled it in the ASUS and created a single simple drive partition for data storage now that the OS is on the fast NVMe.

    That's all it took! No crazy gymnastics installing Intel drivers or anything else like that and yes... IT'S FAST!

    Did this go easier because Windows 10 Creators Update improved internal support or because Samsung Magician and Migration Utility or possibly even the drive firmware has been improved? I don't really know. In the end it doesn't matter because it worked very smoothly and my machine is now booting blazing fast! :-)

    So for those of you dreading the migration to NVMe fear not - apparently it's much easier now than it once was.
    Last edited by ST9752; 09-17-2017 at 12:03 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •