Results 1 to 3 of 3

Hybrid View

  1. #1
    New ROGer Array
    Join Date
    Sep 2017
    Reputation
    10
    Posts
    4

    Problem after install ROG XG Station 2

    Hello,

    I have installed a XG Station 2, and I have these problems:

    - Flight simulator X has stopped working with and without XG station connected
    - All other games works when XG Station is connected, but If I don't use XG Station, all games crashes or don't start (X-plane 11, Dirt3, Project Cars, EuroTruck2, Battelfield4, etc...)

    My notebook is Asus G501VW.

    Anybody knows what's the problem and how I can solve it?

    Thanks.

  2. #2
    ASUS HQ Service Rep Array Bill@ASUS's Avatar
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    433

    Hello nachopr
    Thank you for your inquiry.
    Did your issue occur before you purchased XG station?
    Can you provide more information about your current setup?
    What your current OS version? Driver version? Any error messages that you can share with us?
    Have you updated your BIOS? What's your current BIOS version?
    Thank you

  3. #3
    New ROGer Array
    Join Date
    Sep 2017
    Reputation
    10
    Posts
    4

    Hello,

    Thanks for your reply. I was able to solve the problem unistalling nvidia drivers and reinstalling offical drivers from asus. This is a old version of drivers, but now all the games runs with and without Rog Station connected.

    Tx.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •