Results 1 to 7 of 7
  1. #1
    ROG Enthusiast Array dusty459's Avatar
    Join Date
    Jul 2017
    Reputation
    10
    Posts
    42

    Keyboard And Mouse Disconnect

    When I start my Pc sometime either the Mouse or Keyboard Wont be loaded I have to keep reconnecting them to get it to load

  2. #2
    ROG Enthusiast Array dusty459's Avatar
    Join Date
    Jul 2017
    Reputation
    10
    Posts
    42

    why did the thread dupe its self?

  3. #3
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    301
    Posts
    7,472

    Maybe you lost your connection and tried to submit twice? The two threads had slightly different titles. No biggie. If you get a dupe you can use the report post function and ask a moderator to remove it for you.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  4. #4
    ROG Enthusiast Array dusty459's Avatar
    Join Date
    Jul 2017
    Reputation
    10
    Posts
    42

    Ok thank you

  5. #5
    New ROGer Array
    Join Date
    Sep 2017
    Reputation
    10
    Posts
    6

    Quote Originally Posted by dusty459 View Post
    When I start my Pc sometime either the Mouse or Keyboard Wont be loaded I have to keep reconnecting them to get it to load
    Had this happen to me once so far. Restarted and Keyboard failed to detect and initialise. Pulled out the USB cables and plugged them back in the same USB ports and it initialised. Hasn't happened again yet.

  6. #6
    ROG Enthusiast Array dusty459's Avatar
    Join Date
    Jul 2017
    Reputation
    10
    Posts
    42

    Quote Originally Posted by Kaerar View Post
    Had this happen to me once so far. Restarted and Keyboard failed to detect and initialise. Pulled out the USB cables and plugged them back in the same USB ports and it initialised. Hasn't happened again yet.
    Yes this Seems to Happen to me Often Not sure Why

  7. #7
    ROG Guru: Yellow Belt Array masterac's Avatar
    Join Date
    Mar 2013
    Reputation
    11
    Posts
    150

    Quote Originally Posted by dusty459 View Post
    Yes this Seems to Happen to me Often Not sure Why


    happen to me has well, the pc run fine, then for no reason, i dont get mouse or keyboard response so i simply hard reboot the computer, didnt happen again yet.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •