Results 1 to 4 of 4

Hybrid View

  1. #1
    New ROGer Array
    Join Date
    May 2016

    1950x cpu at 4 ghz struggles for avg 70 fps on witcher 3, gTA5: pubg not playable

    6th day of new 1950x build w msi gaming x 1080 gpu, 32 GB 3200 flare memory- overclocked cpu easily to 4.0 ghz but fps is terrible, struggling to stay at 70 fps on gtA5, witcher 3, 1080p 144mhz monitor. PUBG struggles to be playable at lowest settings. very disapponting. liquid cooled with ek 360 rad kit & $100 ripper ek water block, cpu reads 40 degree celsius, water in and out of rad reads 38 c degrees. Case is 750D with 7 fans, relatively cool. Overclocked the msi gaming x 1080 gpu using jay 2 cents reference video seemed fine but games freeze with jay's 200 mhz overclock, fans running 90 %, gpr temp rises to 70 degrees. games run only with 50 mhz overclock on gpu, then games freeze. Seems 1950 x struggles to keep 70fps on almost any game. set nvidia control panel to power setting maximum as jay suggested. 1950 at stock gets 60 fps in witcher 3. Help, because seems a waste of $550 for zenith mobo & $1000 for 1950x cpu. my intel 5820 x99 cpu puts this 1950x build to shame, which makes no sense. used taskmaster to end corsair commando pro & asus software suites just in case, but no fps help. have latest 801 bios rog & latest nvidia drivers, latest 690 nvme pro drivers ( it sits empty in its nvme slot.) my 5820 gets avg 13o- to 140 fps in swtor 1080p, 144mhz monitor vs 1950x 60 to 80 fps and swtor is an easy game to run. taskmanager shows nothing running. Did not do a clean install of windows 10 pro on my boot ssd. Clean win10 install is next but games run fine but a pitiful low fps 60 to 70 fps so I dont expect that would help. I expected ripper to lag intel 7900 cpu in gaming, as im into after effects, content creation, youtube, but these low fps makes gaming unbearable. My 5820 runs most every game ok. Help, please.

  2. #2
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2017

    ASUS AI-Suite you say?
    Then HPET is probably your problem.

    to fix it:

    Open CMD as an administrator

    bcdedit /enum

    if you see 'useplatformclock' set to true then thats your problem

    Run the following two commands:

    bcdedit /set useplatformclock false
    bcdedit /deletevalue useplatformclock

    Reboot computer: Profit!

  3. #3
    ROG Guru: Yellow Belt Array Cory29 PC Specs
    Cory29 PC Specs
    MotherboardROG Zenith extreme x399
    Memory (part number)G Skill F4-3200C16-8GTZ - 64gb
    Graphics Card #1GIGABYTE GeForce GTX 980 Ti WF
    Monitorcintiq 22hd touch
    Storage #1Sam SSD 850 EVO 1TB
    CPU Coolerxspc block - D5 - 3x120 slim rad
    CaseView 71 (doesn't fit board)
    Power SupplyEVGA supernova 1000G3
    Keyboard K95

    Join Date
    Aug 2017

    "50 mhz overclock on gpu, then games freeze."

    I was having the same issues. It turned out to be unstable ram OC. Ram is extremely touchy on ryzen even more so on TR. My system would seem fine until I tried to run a heavy program then it would just crap out

    software to get**
    monitor software (after it opens click on sensors that's were all the good stuff is )
    1) get hwinfo

    2) Prime95
    *it will most likely throw errors or crash *if it dose that means you have an unstable OC or system

    now the fun part

    check your settings make note of the important ones then delete AiSuite ( I was personally have issues overclocking and keeping things stable because this software was doing its own thing in the background or not doing what it was told even with the version that automatically disabled HPET) *use the cleaner Aisuit3 found in the software side of these forums

    reset your bios to default clear cmos

    set your fan profiles save that profile in the OC section

    everything on auto set your cpu core ratio to 40x restart
    test with prime 95 check your temps with hwinfo
    *play with lower voltages later but you should be under 3.9 my system hovered around 3.6 default somepeople are able to drop about 2.8 but im not that lucky (this saves power and lowers heat)
    ** if I did this with aisuit installed windows would freeze and crash after I deleted Aisuit it worked

    if everything is good then

    Save the profile in bios move onto ram

    set docp ( this is were things get tricky )
    most memory docp will boot to windows fine but cause funny issues (prime95 will freeze or throw errors if you can get that far)
    typically with docp settings set you can drop your speed to 2933 or keep everything on default at 2133 until a new bios
    *basically have to rinse and repeat till you find something that works*

    ** this post as allot of useful settings to play with

    -- hope this helps - there's allot more details to get into these are just bullet points .. I was really frustrated with my build too - in my cause it turned out AiSuit was doing things that I wasn't aware of or in control of
    Last edited by Cory29; 10-16-2017 at 11:48 PM.

  4. #4
    ROG Enthusiast Array JHR1979 PC Specs
    JHR1979 PC Specs
    Laptop (Model)ROG G752VY
    MotherboardROG Zenith Extreme
    ProcessorThreadripper 1950x
    Memory (part number)4x8GB g.skill Flare X 3200/cl14
    Graphics Card #1Gigabyte GTX 1080 G1
    Sound CardSoundblaster Audigy RX
    MonitorAsus PG348Q
    Storage #1Samsung Evo 960 250GB
    Storage #2Samsung Pro 850 250GB
    CPU CoolerNoctua NH-U14S - TR4
    CaseCoolerMaster Cosmos II Ultra tower
    Power SupplyCorsair HX750i
    Keyboard Roccat MK Pro
    Mouse Roccat Kone Pure
    OS W10 Pro
    Network RouterNetgear Orbi

    Join Date
    Apr 2016

    Witcher 3 performance is normal for this CPU, the game really struggles on Ryzen architecture, veeeery intel optimized game.

    Anyways, for gaming use alone, the threadripper is an epic waste of money.


    I tested witcher 3 and SWTOR myself, with 3440 * 1440 resolution.

    In Witcher 3, settings mostly at ultra but with hairworks disabled, the game runs aroudn 65-75fps (capped at 75 because monitor currently running at that speed).

    Swtor runs much faster, all settings maxed, without fps limit, i saw framerates from around 125fps up to 170 fps while running around Alderaan.
    Last edited by JHR1979; 10-18-2017 at 07:47 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts