Results 1 to 6 of 6
  1. #1
    ROG Member Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    10

    G751jt Battery not charging correctly since win10 updated begining of Dec

    Rog G751jt

    Around the beginning of the month
    windows 10 did an update
    after that (not sure if related)

    I now have baterry issues
    My battery never completes charging
    Charger is putting out 19.65Vdc
    Light on laptop is orange, now never green since the update
    when i put the mouse over the battery icon it often says the same thing
    never goes above 85% or so
    no its not just trying to protect the battery

    when you hover over the battery icon it will show you the % charged
    but off and on will say charging or not
    and regardless of how long it says until FULL charge when saying charging
    often the percent never changes
    I.E. 85% charging, full charge in 15 minutes
    2 hours later still sitting at 85% and saying nothing else or the same thing

    never did this before the upgrade
    pretty sure its no the system trying to protect the battery
    because of the hit and miss on the statements that appear when you hover over the bat. icon and the way its acting

    bad news
    since the upgrade win10 did
    there are no more restore points

    not sure if the update caused this or other things did

    anyone else having this issue?

  2. #2
    ROG Guru: Yellow Belt Array
    Join Date
    Jan 2015
    Reputation
    18
    Posts
    129

    Hi southerncalm,
    I have a G751JY w/ Windows 10 on it, I've received all of Windows 10 updates and have absolutely no battery issues. My notebook is always
    plugged in whether it's turned on or off & after 2 years my notebook batteries LED light indicator is always a solid green & the battery indicator
    icon says 97% available (plugged in, not charging). It sounds like this 85% always charging battery issue you're experiencing isn't related to any
    Windows 10 updates (it's probably only a coincidence) and more likely is an indication that your G751JTs integrated battery is slowly starting
    to go bad. As you already know these notebook batteries like all other electronic devices rechargeable batteries deteriorate over time, and
    have a set number of charge cycles before they eventually no longer hold a charge or fully recharge. If you want to extend it's life
    as long as possible you should always leave your notebook (plugged in at all times) whether it's on or off. The more it charges the quicker its set number of total charges is reached until it finally requires replacement.
    Also after receiving all of Windows 10 updates including latest Dec. 2016 update, all my restore points are still present. Not exactly
    sure why your Windows 10 restore points have all disappeared. It could be related to your system drives available, unused space and simply not having enough to store any system restore points any longer (you'd get a Windows 10 system restore error message if you try to create a restore point and don't have enough drive space)? For this MS Windows 10 system restore issue, if you do have plenty of available, unused drive space on your system drive for restore points you should go to the Microsoft Windows 10 website and look
    it up there first. You can also try looking the issue up on the Microsoft Community or ask for help with Windows 10 system restore.
    These are two excellent sites to assist you with any Windows 10 issues. Good luck!
    Last edited by Jon G; 12-22-2016 at 01:21 AM.

  3. #3
    ROG Member Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    10

    10 months later
    still exactly the same
    dead on 85% charging and never more or less
    seems if the battery were going it would see some change in percent
    but nothing
    stays right on 85%
    very strange

  4. #4
    New ROGer Array
    Join Date
    Oct 2017
    Reputation
    10
    Posts
    4

    Hi, I got my asus Rog G752 still hot And ı have just registered here on this forum. I have some issues like asus number pad And batteries same after windows update today(bild 1703) charger displays 95℅ of power on battrry.

    And as of now ı am not able to use keyboard, only some of the shortcut Keys are working VIA Rog button And sound hotkeys....

    I downloaded the easy driver application for checking any updates available or not for devices. And ı started to update them one by one since yesterday and all was fine except asus number pad. I changed it with the new one(İt was hid keyboard device before the update) but it gives a warning as some registry files are missing ı guess and it didnt work after all. Then ı install old drivers again from the same menu. İt was hid keyboard device again and working just fine.


    But after windows creative update build 1703 it is corrupted and ı cannot go to the olduğu one , the option is faded ....

    Any help would be useful , I am new to forum bu the way ....

    Thanks.

    CASPER_VIA_M1 cihazımdan Tapatalk kullanılarak gönderildi

  5. #5
    ROG Guru: Gold Belt Array Clintlgm PC Specs
    Clintlgm PC Specs
    Laptop (Model)Asus G752VY DH72
    MotherboardAsus Z97 Pro WiFi and /Z97 Pro A
    ProcessorI7 4790K
    Storage #1512 GB M.2 Samsung 960 Pro
    Storage #21 TB Samsun 850 Pro
    CaseCool Master Haf
    OS Win 8.1 Pro and Win 10 Pro
    Clintlgm's Avatar
    Join Date
    Jul 2012
    Reputation
    105
    Posts
    4,108

    See ny post, this FCU upgrade should fix you.
    your keyboard issues etc and ATK package needs to be reinstalled
    uninstall Asus update this program is dangerous for your notebook.
    Turn off driver update in windows update
    see my thread about today Fall Creations Upgrade
    G752VY-DH72 Win 10 Pro
    512 GB M.2 Samsung 960 Pro
    1 TB Samsung 850 pro 2.5 format
    980m GTX 4 GB
    32GB DDR 4 Standard RAM

    Z97 PRO WiFi I7 4790K
    Windows 10 Pro
    Z97 -A
    Windows 10 Pro

  6. #6
    Super Moderator Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    143

    I will suggest you to shut down the laptop first, then press the power key 30 seconds to reset Embed Controller and charge the battery again.
    If it is still no work, please take your laptop to our local service center for comprehensive inspection and help you to fix the problem. Sorry for the trouble.
    The following is the contact information:
    http://www.asus.com/support/Service-...All-Countries/
    Also you can contact the local service center for help. The following is the contact information:
    http://www.asus.com/support/CallUs#

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •