Page 3 of 3 FirstFirst 1 2 3
Results 21 to 24 of 24
  1. #21
    ROG Member Array Tbolt214th PC Specs
    Tbolt214th PC Specs
    Laptop (Model)Asus G73-JW, MBPr 15"
    MotherboardAsus ROG Strix Z370-E Gaming
    Processori7-8700k
    Memory (part number)CMK32GX4M4B3600C16
    Graphics Card #1Asus Poseidon GTX-1080-Ti
    Graphics Card #2Asus Poseidon GTX-980
    MonitorAsus PG278B
    Storage #12x Samsung 850 Pro + 1x 960 Evo 250GB
    Storage #2Seagate 2TB HDD 2x
    CPU CoolerWatercool Heatkiller-IV @ MoRa3-360
    CaseCorsair Carbide 500r
    Power SupplyCorsair AXi 1200
    Keyboard Logitech K520
    Mouse Logitech G700
    Headset Logitech
    OS Win10 Pro AMD64
    Network RouterAVM Fritz!Box 7490
    Accessory #1 Oculus Rift
    Accessory #2 TM Hotas, Saitek Combat Rudders
    Accessory #3 Track-IR 5 Pro

    Join Date
    Feb 2017
    Reputation
    10
    Posts
    16

    I got the same board, a Corsair 3600 CL16 16-16-16-36-2T 1.35v Kit 4x8GB and it just wont work with all modules in this Z370 Strix-E.

    Every single module, every combo of pairs works in each possible slot and combination at XMP, JUST NOT ALL 4 TOGETHER.

    I used that kit in my Z270 Prime-A board and they worked flawless from a certain Bios version on. Just this Board really sux with those 3600 16er CL's.


    Fastest I can get them stable is to go XMP but dial them down to 3200MHz at their 3600er settings.


    Since this kit is ~500€ I rather get a new board than a new RAM kit at that speed and size.

  2. #22
    ROG Guru: Yellow Belt Array Carbonicdk PC Specs
    Carbonicdk PC Specs
    MotherboardAsus ROG Strix Z370-E Gaming
    ProcessorIntel i7-8700k
    Memory (part number)F4-3600C16Q-32GTZR
    Graphics Card #1Asus ROG STRIX GTX1080TI O11G GAMING
    Sound CardSchiit Modi 2 Uber
    MonitorAsus MG278Q
    Storage #1Samsung 960Evo
    CaseFractal Design Define R6 - Tempered Glass
    Power SupplyCorsair Professional Platinum Series AX860
    OS Windows 10 64bit

    Join Date
    Mar 2016
    Reputation
    10
    Posts
    143

    Quote Originally Posted by Tbolt214th View Post
    I got the same board, a Corsair 3600 CL16 16-16-16-36-2T 1.35v Kit 4x8GB and it just wont work with all modules in this Z370 Strix-E.

    Every single module, every combo of pairs works in each possible slot and combination at XMP, JUST NOT ALL 4 TOGETHER.

    I used that kit in my Z270 Prime-A board and they worked flawless from a certain Bios version on. Just this Board really sux with those 3600 16er CL's.


    Fastest I can get them stable is to go XMP but dial them down to 3200MHz at their 3600er settings.


    Since this kit is ~500€ I rather get a new board than a new RAM kit at that speed and size.
    Yeah, I'm glad I got another motherboard instead of looking for memory that might also not work on this motherboard.

  3. #23
    ROG Member Array
    Join Date
    Apr 2018
    Reputation
    10
    Posts
    9

    Quote Originally Posted by Carbonicdk View Post
    Yeah, I'm glad I got another motherboard instead of looking for memory that might also not work on this motherboard.
    So getting a new mobo fixed your XMP problems ?

  4. #24
    ROG Guru: Yellow Belt Array Carbonicdk PC Specs
    Carbonicdk PC Specs
    MotherboardAsus ROG Strix Z370-E Gaming
    ProcessorIntel i7-8700k
    Memory (part number)F4-3600C16Q-32GTZR
    Graphics Card #1Asus ROG STRIX GTX1080TI O11G GAMING
    Sound CardSchiit Modi 2 Uber
    MonitorAsus MG278Q
    Storage #1Samsung 960Evo
    CaseFractal Design Define R6 - Tempered Glass
    Power SupplyCorsair Professional Platinum Series AX860
    OS Windows 10 64bit

    Join Date
    Mar 2016
    Reputation
    10
    Posts
    143

    Quote Originally Posted by Qutip View Post
    So getting a new mobo fixed your XMP problems ?
    Yes XMP and general issues getting them up to their rated spec of 3600mhz using any settings, including horrible timings. My new Gigabyte board has no stability issues with my 4 stick kit. Asus claimed I probably had a weak memory controller on my CPU but since I use the same CPU on this new board there's only my Z370-e left to blame.

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •