Results 1 to 4 of 4
  1. #1
    New ROGer Array Oakhome PC Specs
    Oakhome PC Specs
    MotherboardASUS ROG Rampage VI Extreme
    ProcessorCore i7-7800X
    Graphics Card #1ASUS GeForce GTX 1080Ti ROG Strix Gaming

    Join Date
    Oct 2017
    Reputation
    10
    Posts
    11

    No POST / MB lights come on

    Absolutely stumped at this one.

    I'm not able to get a post screen/bios screen on first time boot. Everything is dead - no system fans, no CPU fan, no RAM lights, GPU isnt on - except for

    • the RGB lights on the MB
      the orange light bottom right I think is bios version
      a red light/led right above the heatsink pipe coming from the IO to heat shield above CPU
      the start and reset button are lit


    To make things more fun, all parts in the build are new.

    PCI/e switch is on. On the 4 button switch all are on. Power is coming from my PSU to the EATXPWR 24-pin on the right side of the MB. I've not added power to the 12V ones.

    Anything I've missed ? Will try pulling out the GPU next, and powering via the 8-pins cause why not at this stage

  2. #2
    ROG Enthusiast Array thr23 PC Specs
    thr23 PC Specs
    MotherboardAsus ROG Rampage VI Extreme
    ProcessorIntel Core i7-7820X
    Memory (part number)G.Skill Trident Z RGB DDR4, 4x16GB, 3600MHz (F4-3600C17Q-64GTZR)
    Graphics Card #1Asus ROG Strix GeForce GTX 1080 Ti OC
    Storage #1Samsung SSD 960 PRO 1TB
    Storage #2WD Red 10TB
    CPU CoolerNoctua NH-D9L
    CaseIn-Win 805 Red
    Power SupplyThermaltake Toughpower iRGB PLUS 1250W Titanium

    Join Date
    Oct 2017
    Reputation
    28
    Posts
    30

    You need to connect power to the 8-pin CPU power connector on the upper side of the board. Near the red-glowing LED.

  3. #3
    New ROGer Array Oakhome PC Specs
    Oakhome PC Specs
    MotherboardASUS ROG Rampage VI Extreme
    ProcessorCore i7-7800X
    Graphics Card #1ASUS GeForce GTX 1080Ti ROG Strix Gaming

    Join Date
    Oct 2017
    Reputation
    10
    Posts
    11

    I do ? oops - let me just go and do that

  4. #4
    New ROGer Array Oakhome PC Specs
    Oakhome PC Specs
    MotherboardASUS ROG Rampage VI Extreme
    ProcessorCore i7-7800X
    Graphics Card #1ASUS GeForce GTX 1080Ti ROG Strix Gaming

    Join Date
    Oct 2017
    Reputation
    10
    Posts
    11

    That did indeed make the red led go away, but unfortunately still no POST and nothing powers up

    I'm a moron - that did the trick, thank you so much thr ! (+rep if I'm allowed)
    Last edited by Oakhome; 10-29-2017 at 04:37 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •