Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
  1. #11
    New ROGer Array
    Join Date
    Oct 2017
    Reputation
    10
    Posts
    10

    Found the program crashing my usb ports!!!!!

    CORSAIR LINK 4 every time i start it it crashes my USB ports .... what the hell

  2. #12
    ROG Guru: Yellow Belt Array cekeu PC Specs
    cekeu PC Specs
    MotherboardROG Rampage VI Extreme Encore
    ProcessorIntel Core i9-10920X
    Memory (part number)(Corsair) CMT32GX4M4Z3200C16
    MonitorROG SWIFT PG27UQ
    CPU CoolerEK water cooling
    Power SupplySEASONIC PRIME 1300 W Platinum
    OS Windows 10 64Bit

    Join Date
    Jun 2013
    Reputation
    11
    Posts
    153

    My personal experience made me realize that the USB driver downloaded to the motherboard support caused these problems of unwanted disconnections.
    I uninstalled ASUS USB drivers and i have searched and updated my drivers by Windows update and since I have no problems with unwanted disconnections.
    For Corsair Link, turn off the PC and unplug the USB plug from the motherboard, and reconnect it. Then turn on your PC and check, it should get better.
    Last edited by cekeu; 11-02-2017 at 06:26 PM.

  3. #13
    New ROGer Array
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    11

    glad im not the only one...

    Curious to know whether or not Asus has offered a fix for this problem on the GL704GW?
    Consideirng its virtually a desktop replacement for creators (as well as gamers obviously) we'll be plugging in and using exernal devices on teh regular...

    I went and did those power tweaks as others have suggested and Im glad I found this problem now and not when Im rendering video or doing something critical.
    One thing however is that if anyones experiencing this problem, DO NOT cut and paste... copy and paste is ok and your files are fine, but cutting will be a problem..

    Thing is, it was disconnecting when the drives were in use. One drive was a SSD through the USBc and the other a 2.5' HDD..both using USB to sata connections without power coupling.. Regardless of what i was doing and at this time i was managing my archives so big chunks of copypasting... but even after making those power tweaks and as I literally write this, its disconnecting. This only happens when using the USBc port though... when using the standard ports it doesnt cut out. ...

    So i connected a power supply to the one connected to the standard USB port. The USBc adapter doesnt have the option to run external power so the SSD is connected to tht one as it needs less power... so far so good...

    but I wont have the option of a power coupling unless I get myself a USB to power DC input and use another USB port to feed power...

    Thats my expereince anyway.. There are afew other variables and drive combinations I havent mentioned but this seems to be the problem....

    So yeah, if anyone knows of a permanent fix that wont brick my mobo, that would be appreciated.

  4. #14
    New ROGer Array
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    11

    quick follow up

    so as mentioned previousl y connected a power supply to the external hdd adapter...
    It didnt fix the problem.. it slowed down the rate in whcih the disconnections occur, but they still happen...

    I noticed it happens on the OSBc more often than the standard port, but I dont have another adapter to check this.

    In any case, even with a powered HDD and another powered throguh USBc, those problems still happen...

    not mipressed...

    any help is apprcaited...

  5. #15
    New ROGer Array
    Join Date
    Apr 2020
    Reputation
    10
    Posts
    1

    Hi all, adding to this thread as I'm having the same issue. While the normal front USB ports work fine, the blue USB 3.1 ports disconnect and reconnect every few minutes. Tried uninstalling the driver but it didn't help. I have a Z370-H MB. Any help would be appreciated.
    Last edited by Proeliator; 04-29-2020 at 03:59 AM.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •