Results 1 to 1 of 1
  1. #1
    ROG Enthusiast Array Saltgrass PC Specs
    Saltgrass PC Specs
    MotherboardMaximus X Hero (Wi-Fi)
    Processori7 8700K
    Memory (part number)HX433C16PB3K4/32
    Graphics Card #1EVGA GTX 1080 Ti
    Sound CardOn Board
    MonitorLG 34UC89G
    Storage #1Samsung 970 Pro 1 TB
    Storage #2Samsung 860 Pro 1 TB
    CPU CoolerCooler Master Hyper 212X
    CaseCooler Master
    Power SupplyAntec HCP Platinum 1000
    Keyboard Black Widow Ultimate
    Mouse Logitech G600
    Headset/Speakers Logitech wired 5.1
    OS Win 10 Pro
    Network RouterROG Rapture GT-AX11000
    Accessory #1 VR Headset
    Accessory #2 Saitek X53

    Join Date
    Jan 2014
    Reputation
    10
    Posts
    56

    Bios Setup User Interface Problems Maximus Hero X (Wi-Fi)

    I have two problems with the current Bios setup UI on this system. First, I am using a display which seems to cause a popup window making note of an incorrect resolution. It has two options, not show message again or cancel. Neither one is selectable since the mouse cursor rides beneath the message. Any attempt to select one option just causes some setting on the main page to react.

    Secondly, the 144 Hz 2560x1080 monitor uses DP for the video signal. The Bios Setup does not seem to recognize that input and the screen stays black. It does see HDMI. Since I just did the Bios upgrade to 1301, these problems seems to be current and still need to be addressed.

    My video output comes from a EVGA GTX 1080 Ti video card.

    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •