Results 1 to 2 of 2

Hybrid View

  1. #1
    New ROGer Array
    Join Date
    Nov 2017
    Reputation
    10
    Posts
    1

    ASUS REFUSING RMA HERO maximus VII returned damaged board not responding

    In the beginning of January I started having problems with my system not posting. I tried all the common fixes, but narrowed it down to my motherboard. I was getting the Q code 00 which after reading online seems that there is something with the CPU not being recognised. I tried the CPU in another board and it worked fine so I assumed something was wrong with the mobo. I filled out the RMA form and sent my motherboard off with no troubles thinking it would be fixed but was shocked when it was returned with a no repair slip and corrosion + scratches to the area that i said was the problem on the rma form (the bios chip). For the last 3 weeks I have continuously been contacting the support by calling and emailing but everyone just sends me in circles. I've already had to purchase a new motherboard in the mean time and if this is how asus support is it will be the last time i purchase an asus product. If anyone needs the case numbers Ill post them below. I have a few more written down somewhere but I think this amount already shows how useful the support has been...

    First RMA number: AUAAH30944
    Case ID numbers: U171007173, U171103138, U170107954, U170107893

  2. #2
    Moderator Array
    Join Date
    Jun 2016
    Reputation
    10
    Posts
    241

    Hi True2456,

    After verifying with our RMA team, it is confirmed that your motherboard was badly corroded beyond repairable level (PCB damage), hence was rejected.
    Unfortunately environmental damage is not covered under warranty, I am afraid there is very limit to how we can assist you on this one.

    regards,

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •