Results 1 to 2 of 2
  1. #1
    ROG Member Array
    Join Date
    Mar 2017

    ROG Spatha won't connect wireless


    after I've RMA'd my first ROG Spatha mouse about 3 months ago, which just turned off after a firmware update and never came back to life, I'm now on my second unit and it's been working and updating fine so far.
    I just tried to connect it wirelessly to the dock, and it just won't connect whatever I do. I did this fine with my first unit and never had any issues whatsoever, but this one just won't connect. I am on the latest Armoury and firmware, tried syncing, diconnect - turn on and reconnect, clicking the left mouse button, nothing.
    Once I start the sync the green light on the dock starts blinking and when I click the sync button on the mouse it stops. then both turn off all their lights and just nothing happens.
    Am I missing something? It works fine with the cable and battery is reported as 100% in Armoury.

  2. #2
    ASUS HQ Service Rep Array Bill@ROG's Avatar
    Join Date
    Dec 2015

    Hello siopoudis
    I'm not sure what is going on here
    but I would suggest to send it for RMA if you are unsure what to do next, thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts