Results 1 to 2 of 2
  1. #1
    ROG Member Array Darth Affe's Avatar
    Join Date
    Oct 2017
    Reputation
    10
    Posts
    6

    Access Violation / Wrong EnumerateMB-Result

    Hey guys,

    lately I've had some issues with access-violations from the SDK in different constellations (multiple people with different setups).
    I tracked them down and I'm pretty sure they are caused by calls to SetMbMode (but i think other methods would be affected too) with an invalid handle. While I understand why the error occurs in such a situation, I'd highly appreciate if this case would be checked in the SDK and handled with an error-code or an exception that doesn't corrupt the application state.

    The second important point about this is, that it's ultimately only fighting the symptoms. The root-cause of the problem seems to be a wrong (to big) count returned by EnumerateMbController. This seems to happen quite often (for all types of devices), for example it shows a graphics card for me even if I don't have a aura-ready one, but only the second mainboard (I don't have that issue, but some other people get that instead of the graphics card) returned seems to reliable lead to this issue.

    I'm not sure what's the better and easier solution on your side but either should the Enumerate-Method work reliable or it should be possible to test if the handle is working without causing access violatinos in the SDK.

  2. #2
    ROG Member Array kekkokk PC Specs
    kekkokk PC Specs
    Laptop (Model)Macbook Pro 2011 & 2012
    MotherboardAsus Strix Z270E
    ProcessorIntel 7700k @ 5ghz
    Memory (part number)Gskill Trident Z 3200 16gb
    Graphics Card #1Asus Strix 1070 OC
    MonitorBenq Zowie xl2411
    Storage #1Samsung nVME 960 evo
    Storage #22 x Crucial mx 300 500 gb (raid 0)
    CPU CoolerNzxt kraken x62
    CaseEnthoo Phanteks evolv ATX Tempered glass
    Power SupplyCorsair Rmi 750
    Keyboard Asus Claymore Core
    Mouse Logitech g502
    Headset Logitech g930
    Mouse Pad Hp Omen
    Headset/Speakers KRK Rokit 6

    Join Date
    Apr 2018
    Reputation
    10
    Posts
    13

    I'm having the same problem too...
    Different values for different computer.
    I have a zotac 1050ti and still see the 1 gpu controller. also hangs with lots of asus an non-asus motherboard when calling enumeratembcontroller

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •