Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Nov 2017
    Reputation
    10
    Posts
    1

    Spatha suddenly stop functioning.

    Good day,

    My Spatha just ran on an issue. i was just using it last night then shut down my pc before going to bed. the next morning when im about to use my pc, mouse isnt working(mouse cursor not moving) YET all buttons are okay. but when im updating the mouse's firmware (using both Armoury or the firmware driver from the website) the mouse is functioning (without any lights) so i know that the sensor is working. yet when the update is finish, it wont move again. Tried many armoury versions and both firmware version but mouse isnt working until today. Tried the drain battery technique: failed. Tried the Hold left+mid+right click before inserting the usb cable technique: failed. Tried to disconnect the battery: failed. I was hoping someone can help me here.

    Thank you!

  2. #2
    Administrator Array MasterC@ROG's Avatar
    Join Date
    Aug 2014
    Reputation
    158
    Posts
    2,008

    Can you take a screenshot of the Settings page which shows the software, dock, and mouse firmware versions?
    Also, check your inbox, I'll send you the latest firmware to flash manually.

    Please check the sensitivity (DPI) setting.
    Last edited by MasterC@ROG; 07-09-2018 at 07:22 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •