Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Nov 2017
    Reputation
    10
    Posts
    1

    ROG Armoury wont install

    when I try to download the ROG armoury software on my it crashes before I can install with error number 0x80040707 Description: DLL function call crashed: IsSupported.IsASUSMB. What is going on?

  2. #2
    New ROGer Array
    Join Date
    Jun 2017
    Reputation
    10
    Posts
    2

    Having the exact same issue, not sure if it is something to do with corsair software or something else conflicting with the install. I did get the old Version 2.108 ROG Armoury Driver to install ok but still cant manage to install the latest version of Armoury.

  3. #3
    ROG Enthusiast Array
    Join Date
    Jan 2018
    Reputation
    10
    Posts
    29

    Quote Originally Posted by Nlcko View Post
    Having the exact same issue, not sure if it is something to do with corsair software or something else conflicting with the install. I did get the old Version 2.108 ROG Armoury Driver to install ok but still cant manage to install the latest version of Armoury.
    Were you able to fix the issue? I can't install armoury to my w10 64bit, any of them. I have the sam problem.

  4. #4
    ROG Member Array
    Join Date
    Mar 2018
    Reputation
    10
    Posts
    6

    Same issue there, while installing Armoury v2.04.07

    Windows 10 x64

    Fresh install out of the box :

    ASUS SCAR-GL503VM-ED033T
    ROG PUGIO MOUSE

    Error :
    Dll function call crashed: IsSupported.IsASUSMB
    Last edited by krisfr92; 03-25-2018 at 07:35 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •