Results 1 to 5 of 5
  1. #1
    ROG Member Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    7

    Disable GL502VM Turbo Boost

    Hi there,
    So I've been researching a LOT about how to lower the temps of my GL502VM laptop. After trying different cooling pads, undervolting, changing the profile of my GPU on afterburner. Which worked in many games (PUBG or Fallout 4 don't rise the temps so much). For some others the only solution I found is to disable Turbo boost and get used to the fact that my laptop will run at stock frequencies (2.8 GHZ in my case).

    Since Asus Laptops don't allow to disable it in BIOS the most common solution is to go to the Power settings in control panel and change the Maximum processor state to 99%, which limits it a bit below the stock freq, in my case to 2.69 GHZ.

    Looking around I found a Registry editor file on this post:

    http://www.geeks3d.com/20170213/how-to-disable-intel-turbo-boost-technology-on-a-notebook

    Wich adds the option to Disable the turbo boost and a few other options that I haven't tried:

    Click image for larger version. 

Name:	Screenshot_3.jpg 
Views:	152 
Size:	77.9 KB 
ID:	69521

    Using the "Disable" locked my freq to 2.8 so it seems to work well and it's much better than the 2.69 of using the 99% option.

    I will test the other options this week and come back with some results.

    here's the link to the Registry editor:

    http://www.geeks3d.com/dl/showd/10060

    Sorry if this is a repost. I looked around a bit and haven't found this in the forum.

    Hope this helped!.

    Cheers,

  2. #2
    ROG Guru: White Belt Array
    Join Date
    Apr 2017
    Reputation
    14
    Posts
    91

    Very interesting

    Hi!
    It's very interesting, keep posting. I've only now noticed that 99% Maximum power state gives -100Mhz for stock frequency. However, I wonder if it will make noticeable difference in games. As I know, differences between core I5-7300HQ and core i7-7700HQ in games gives maximum 5 additional fps. If the same GPU is used, of course.

  3. #3
    ROG Guru: White Belt Array
    Join Date
    Apr 2017
    Reputation
    14
    Posts
    91

    You can also do it manually: call register editor (Win+R → regedit), go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\be337238-0d82-4146-a960-4f3749d470c7 and in Attributes graph set "Attributes"=dword:00000002. Then in power plan options already mentioned "Processor performance boost mode" will appear. Select "Disable". Full list of modes:
    dword:00000000 - Disabled - Don't select target frequencies above maximum frequency.
    dword:00000001 - Enabled - Select target frequencies above maximum frequency.
    dword:00000002 - Aggressive - Always select the highest possible target frequency.
    dword:00000003 - Efficient enabled - Select target frequencies above maximum frequency if hardware supports doing so efficiently.
    dword:00000004 - Efficient aggressive - Always select the highest possible target frequency if hardware supports doing so efficiently.
    Last edited by Lord Obsidian; 03-02-2018 at 11:19 PM.

  4. #4
    New ROGer Array
    Join Date
    Oct 2018
    Reputation
    10
    Posts
    2

    Quote Originally Posted by pepilo View Post
    Hi there,
    So I've been researching a LOT about how to lower the temps of my GL502VM laptop. After trying different cooling pads, undervolting, changing the profile of my GPU on afterburner. Which worked in many games (PUBG or Fallout 4 don't rise the temps so much). For some others the only solution I found is to disable Turbo boost and get used to the fact that my laptop will run at stock frequencies (2.8 GHZ in my case).

    Since Asus Laptops don't allow to disable it in BIOS the most common solution is to go to the Power settings in control panel and change the Maximum processor state to 99%, which limits it a bit below the stock freq, in my case to 2.69 GHZ.

    Looking around I found a Registry editor file on this post:

    http://www.geeks3d.com/20170213/how-to-disable-intel-turbo-boost-technology-on-a-notebook

    Wich adds the option to Disable the turbo boost and a few other options that I haven't tried:

    Click image for larger version. 

Name:	Screenshot_3.jpg 
Views:	152 
Size:	77.9 KB 
ID:	69521

    Using the "Disable" locked my freq to 2.8 so it seems to work well and it's much better than the 2.69 of using the 99% option.

    I will test the other options this week and come back with some results.

    here's the link to the Registry editor:

    http://www.geeks3d.com/dl/showd/10060

    Sorry if this is a repost. I looked around a bit and haven't found this in the forum.

    Hope this helped!.

    Cheers,
    Do you have something like this for GPU?
    I have a ROG Strix GL503GE and the GPU fan speed is getting stuck at MAX 7000rpm even at Idle

  5. #5
    ROG Guru: Orange Belt Array FULLMETALJACKET7's Avatar
    Join Date
    Mar 2018
    Reputation
    46
    Posts
    492

    Quote Originally Posted by salimogs View Post
    Do you have something like this for GPU?
    I have a ROG Strix GL503GE and the GPU fan speed is getting stuck at MAX 7000rpm even at Idle
    That's not how it works. If the temperature is low but the fan is still going too fast, you got a problem somewhere else.
    Try changing the fan speed using rog gaming center. See if it responds.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •