Results 1 to 4 of 4
  1. #1
    ROG Guru: Yellow Belt Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    136

    Issues with new Asus Maximus X Formula and Windows 10 Pro

    I just picked this board up with 8700k. I installed Windows 10 Pro 1709 build 16299.125 and the newest Asus Drivers and Utilities.

    When using Edge if I search with Google or Bing and guessing any search engine when I click on one of the results links it takes forever for the link to even start to load. System isn't locked up it just takes a long time. Also seems to happen if try to download anything via browser. If I use IE 11 I don't seem to have this issue.

    Anyone have any ideas?

  2. #2
    ROG Guru: Yellow Belt Array no1yak PC Specs
    no1yak PC Specs
    MotherboardMaximus Hero X I Wi-Fi/ Hero IX
    Processori9 9900KF/ i7 7700K both @ 4.7Ghz
    Memory (part number)Gskill F4-3200C16D / Corsair 2400 LPX
    Graphics Card #1Evga GTX 1070 SC ACX3 / Evga 1060 SC
    Sound CardEssence One DAC Muses edition
    MonitorEizo CG275W/ Dell U2719D
    Storage #1Samsung 970 EVO Plus NVMe / 950 Pro
    Storage #2Samsung EVO 950 Pro M.2 + 850 Pro 1TB
    CPU CoolerCorsair 150i pro/Noctua NHu-14S
    CaseCorsair 500D/ Corsair 450D
    Power SupplyEvga 650 P2 /Corsair HX750
    Keyboard Cherry MX6
    Mouse Corsair M65
    Headset/Speakers Corsair SP2500 + Senn HD650 + HD 600
    OS Windows 10 Pro x64 20H2

    Join Date
    Jun 2015
    Reputation
    10
    Posts
    156

    Have you tried another browser? do you get the same problem in IE or Firefox.

  3. #3
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Maximus IX Code
    Processori7-7700k 5.2GHz Delidded
    Memory (part number)16GB G.Skill Trident Z 4025MHz 17-17-17-39-2T
    Graphics Card #1Titan Xp - EKFC waterblock
    Graphics Card #2Titan Xp
    Sound CardROG SupremeFX 2015
    MonitorHP ZR30w
    Storage #1Toshiba VX500 256GB
    CPU CoolerSwiftech Apogee GTZ
    CaseThermaltake Armor+ VH6000
    Power SupplyEVGA Supernova 1600w Titanium
    Keyboard Cyberpower Skorpion K2
    Mouse ROG Chakram Core
    Headset Sennheiser HD6XX / Modmic 5
    Mouse Pad Steelseries QCK Prism XL
    OS Windows 10 Home 64 bit
    Accessory #1 Asus optical drive
    Accessory #2 Koolance ERM-2K3U
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    308
    Posts
    16,437

    Hi guys

    I use google chrome.

  4. #4
    ROG Guru: Yellow Belt Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    136

    So looks like issue with Edge. I followed this post where deleted Edge and reinstalled it.


    https://www.reddit.com/r/Windows10/c...ses_microsoft/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •