Results 1 to 5 of 5
  1. #1
    ROG Member Array
    Join Date
    Nov 2017
    Reputation
    10
    Posts
    17

    CPU upgrade... Threadripper should be called Hair ripper

    First post, be gentle?

    Debated writing this at all because on one hand I view it as free tech support and thus reward for bad behavior. On the other, people should really be warned.

    First, to be clear I'm not an electrical engineer, nor do I follow the myriad of forms online surrounding hardware in general. Quite frankly I find many of them to be filled with more trolls / marketing people ready to pounce on newbs, then actually helpful. On with it though...

    I bought into Threadripper not to necessarily be the fastest, but on par with Intel for quite a bit less. The workloads I throw at it scales for the most part already and I'm quite aware of NUMA, scheduling, etc... I needed more cores, pure and simple. Since it was an entirely new platform I expected some churn and costs. What I wasn't expecting was feeling like a beta test drone for hardware that costs several thousand between CPU, Memory, Board, etc. In the end, I ended up with:

    - Swapping 3 power supplies
    Currently on using a fraction of a 1.5kW EVGA PSU as it got rid of coil whine on the 1080s

    - Swapping 2 montherboards, owning two
    By far the biggest headaches came from this. Replaced two Gaming 7 boards before giving up/in to the Zenith Extreme.

    Getting bit by what I'm finding are bugs other people have noticed like the HPET timer (seriously, wtf?) - that alone wasted about a week of testing as it was randomly affecting VMs. Latest issue is the board doesn't appear to support two 1080TI's. When I try both of them it throws up an error 82 - VGA BIOS Load Fail? Individually both cards work!

    The other major issue with both boards (Aorus and Asus), are pcie errors. Reported by others as well but again point to more hardware problems then software. Interestingly enough in the process of trying to find out what was going on with the 1080s, I found disabling (dip switches) the first PCIE slot on at least the Zenith, completely eliminated the PCIE errors!

    I'm now at a point where I have to rip the Asus board apart so I can RMA the damn thing (eta from Asus is 1 month)

    - 4 video cards replaced due to faulty hardware
    Technically EVGA boards but still, what a nightmare. Talking $1k+ hardware alone, for each.

    - RAM swapped, twice due to not being detected
    Drove two and a half hours to get RAM. Crazy. Only other option was waiting a week + for shipping.

    - 2 failed 10TB drives, DOA
    Segate Ironwolfs . Never again (ZFS rocks)

    - Many km wasted driving to different Canada Computers locations for parts
    Boggles my mind how centralized hardware has become. There are literally only a few vendors I can buy from and only one has physical locations. Down sides is several of their locations are quite racist but I won't get into that here.

    - Many, many hours wasted tinkering
    At one point I disconnected any storage and even GPUs to save on their constant power cycling because especially when it came to the RAM, good god was there a lot. At least Asus is addressing some of the random rebooting in BIOS updates (thought it was related to the auto overclocking).


    Either I got very unlucky with hardware or the platform simply is unstable / rushed. I'd expect and hope those issues are ironed out but this little experience will forever be in the back of my head when buying hardware again. Hardware vendors should not be patting themselves on the back over this. Had it not been for a few youtube channels like Level1techs doing the grunt work testing, it's unlikely you'd have those sales.

    tl;DR - Is or was anyone bitten by the quirk with running two 1080TI's in this board?

  2. #2
    New ROGer Array andy_lamp PC Specs
    andy_lamp PC Specs
    MotherboardASUS Zenith Extreme
    ProcessorAMD Threadripper 1950x
    Memory (part number)G.Skill F4-3200C16Q-32GTZR
    Graphics Card #1Gigabyte G1 GTX 980 Ti
    Graphics Card #2Gigabyte 750 Ti
    MonitorDell U3017
    Storage #1Intel Optane 900p 480GB (PCI-e)
    Storage #2Samsung 850 Evo
    CPU CoolerEnermax TR4 360
    CaseCorsair 600q
    Power SupplyCorsair AX1200i
    OS Windows 10 x64 (1709)

    Join Date
    Oct 2013
    Reputation
    10
    Posts
    14

    I completely agree -- I have two GPU's and the problems with the platform have been immense... inconsistent clocks, freezes after sleep or idling after a long time, CPU PWM problems, DRAM problems (and I picked ones straight from QVL)... so I know exactly how you feel. Hopefully, ASUS will get its **** together and iron out these issues; it's an extremely expensive product as well...

  3. #3
    ROG Member Array
    Join Date
    Jan 2018
    Reputation
    10
    Posts
    6

    dang. wish I saw this before I built. have always used asus for intel, up to 5-6 builds now no problem. my first amd build and what a mess. nothing works (cpu socket screws?!) and/or is consistent reported error. shame on asus

  4. #4
    ROG Member Array
    Join Date
    Nov 2017
    Reputation
    10
    Posts
    17

    Quote Originally Posted by Capo99999 View Post
    dang. wish I saw this before I built. have always used asus for intel, up to 5-6 builds now no problem. my first amd build and what a mess. nothing works (cpu socket screws?!) and/or is consistent reported error. shame on asus

    If you mean the thread ripping (no pun intended I swear!) - it became fairly well known. Given it affects different boards I'm less inclined to believe it's an Asus specific problem though. Short version is on some boards you have to use an extremely unnatural amount of force before the screws will catch. I ran into it with tthe Aorus board but not Asus; Others have the opposite luck. Screws are literally millimeters off.

  5. #5
    ROG Enthusiast Array
    Join Date
    Dec 2017
    Reputation
    10
    Posts
    26

    I think maybe you just got extremely unlucky, I had issues myself had to return a motherboard and that motherboard made a weird electrical hum/whind to it that I didnt really pay it any mind till I got the replacement board and realized that electrical hum was done with. The issue I had the most with threadripper was just dialing it in, the way it ships stock is stupid imo who the hell wants to hear your fan zoom up to 100 every 2 seconds just to have 1 core shoot up to 4.1ghz that got on my nerves so I underclocked mines and it performs better than how it came stock with all that auto BS. But other than that everything I encounter was just windows trying to force drivers on me that didnt work but once i got that solved did a fresh install with all the new knowledge I acquired I applied to the fresh install and now thread ripper is zooming, cinebench etc is not breaking any numbers infact probably lower than other 1950x but in real day use it alot snappier than others 1950x, My friends has one and his feel sluggish compared to my setup.

    Although I can only imagine your pain with 2 1080's , I had 1 1050 and it was a pain to get it right lmfao.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •