Results 1 to 2 of 2
  1. #1
    ROG Member Array
    Join Date
    Mar 2016
    Reputation
    10
    Posts
    18

    Question G751JT Battery flashing orange/green then no LED at all

    I was playing a game today and noticed my fans were humming louder than usual and the battery LED was flashing orange/green. I unplugged the AC adapter charging my laptop and did a shutdown through clicking the Windows button, but the battery LED indicator stayed green. After booting the laptop, I tried deleting "Microsoft ACPI-Compliant Control Method Battery" from Device Manager -> Batteries, then rescanned for hardware changes (Actions -> Scan for hardware changes). The orange/green flashing continued, so I performed a hard shutdown by holding down the power button until the LED indicator stopped flashing. Waited for 5 minutes then turned on the laptop again, but now the LED does not light up while on battery and it shows a solid orange light when plugged in to the AC adapter. 10 minutes after I plugged in the adapter plug into my laptop the solid orange LED turns solid green. I have been using this laptop since March 2016 and current OS is Win 10 Home ver. 1709, build 16299.125.

    Does the laptop need battery re-calibration or a battery replacement?
    Last edited by Linerax; 12-29-2017 at 11:44 PM.

  2. #2
    ROG Member Array
    Join Date
    May 2015
    Reputation
    10
    Posts
    7

    Quote Originally Posted by Linerax View Post
    I was playing a game today and noticed my fans were humming louder than usual and the battery LED was flashing orange/green. I unplugged the AC adapter charging my laptop and did a shutdown through clicking the Windows button, but the battery LED indicator stayed green. After booting the laptop, I tried deleting "Microsoft ACPI-Compliant Control Method Battery" from Device Manager -> Batteries, then rescanned for hardware changes (Actions -> Scan for hardware changes). The orange/green flashing continued, so I performed a hard shutdown by holding down the power button until the LED indicator stopped flashing. Waited for 5 minutes then turned on the laptop again, but now the LED does not light up while on battery and it shows a solid orange light when plugged in to the AC adapter. 10 minutes after I plugged in the adapter plug into my laptop the solid orange LED turns solid green. I have been using this laptop since March 2016 and current OS is Win 10 Home ver. 1709, build 16299.125.

    Does the laptop need battery re-calibration or a battery replacement?
    My JT also is showing no charging led at all on the front, and 0% in system tray, starting about a week ago.
    If i pull my power cord out, it shuts down (power off)
    I bought mine around mid-2016. Wondering the same..?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •