Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    New ROGer Array
    Join Date
    Aug 2016
    Reputation
    10
    Posts
    20

    SOLUTION to ENABLING ALL drivers for Stereo output

    I just recently bought the asus 7.1 centurion and after buying i realized that the sound was terrible as it only USED the front channel for stereo and not the sub. also for games that doesn't support 5.1 or 7.1 it only uses stereo. Here are the steps

    1. download EqualizerAPO and configure it to your headset device on popup.
    2. download peace equalizer for equalizerAPO and install.
    3. After both of them are installed, run the peaceUI and click on the Effects button on the right hand side
    4. When the effects menu pops up turn the "upmix" to on and it will utilize all drivers for stereo

    5. IF you want the Subwoofer to work properly, click on "subwoofer" on the right hand side. Navigate to the equalizer and underneath the eqaulizer @ 60hz, click on the filter box and choose "Low Pass Filter"

    IF you don't have 60hz, edit the frequencies in the equalizer and change it to 60hz although you can experiment with this as i do NOT know what sounds best for this subwoofer.
    Short and quick but let me know what you guys think.
    Last edited by XtraArrow; 01-23-2018 at 02:27 PM.

  2. #2
    ROG Member Array
    Join Date
    Dec 2016
    Reputation
    10
    Posts
    9

    Thanks

    Thank you very much for that great information.

    This is the tool I was looking for. With the integrated channel routing sounds from the rear are sounding as they should. The per-channel equalizer is awesome!!!

    And with my special adaptor, i do not need the asus box anymore, saved 2 USB Ports and made my integrated 7.1 soundcard useful again...
    Last edited by Mollari; 01-20-2018 at 12:48 PM.

  3. #3
    New ROGer Array
    Join Date
    Aug 2016
    Reputation
    10
    Posts
    20

    Quote Originally Posted by Mollari View Post
    Thank you very much for that great information.

    This is the tool I was looking for. With the integrated channel routing sounds from the rear are sounding as they should. The per-channel equalizer is awesome!!!

    And with my special adaptor, i do not need the asus box anymore, saved 2 USB Ports and made my integrated 7.1 soundcard useful again...
    Glad it worked for you pal, if we could just get the Subwoofer to work for all channels then it would be perfect!

  4. #4
    ROG Guru: Black Belt Array toronto699 PC Specs
    toronto699 PC Specs
    Laptop (Model)G752-VY-DH78K , G751-JYDH72X
    MotherboardRog Tytan G30AB
    Processori7-4770K
    Memory (part number)32GB
    Graphics Card #1Asus Gold20th GTX980Ti
    Sound CardDell X-Fi Audigy SoundBlaster
    Monitor3 Acer K272HL
    Storage #1118 GB/OS
    Storage #22.72 TB
    CPU CoolerIntegrated Liquid-Cooled CPU
    CaseG30AB
    Power SupplyAsus 700 Watt
    Keyboard Razer BlackWidow Ultimate
    Mouse Razer Diamond Back
    Headset Sony Studio Professional , Razer Seiren Mic
    Mouse Pad Razer FireFly
    Headset/Speakers Logittech 5.1 Z-5500
    OS W 10
    Network RouterSagemon Fast 5250 Hub 2000

    Join Date
    Aug 2014
    Reputation
    94
    Posts
    2,428

    Could You Please Post Links For The Apps Please

  5. #5
    ROG Member Array
    Join Date
    Dec 2016
    Reputation
    10
    Posts
    9

    Quote Originally Posted by XtraArrow View Post
    Glad it worked for you pal, if we could just get the Subwoofer to work for all channels then it would be perfect!
    Yeah, you can activate the Subwoofer for all channels by rerouting all channels to the LFE/SUB channel. It is working on my machine and sounds perfect with a proper equalizer setting for that LFE/SUB channel

  6. #6
    New ROGer Array
    Join Date
    Aug 2016
    Reputation
    10
    Posts
    20

    Quote Originally Posted by Mollari View Post
    Yeah, you can activate the Subwoofer for all channels by rerouting all channels to the LFE/SUB channel. It is working on my machine and sounds perfect with a proper equalizer setting for that LFE/SUB channel
    Thank you, I've edited the OP with brief instructions on how to add a Low pass to make the subwoofer work as it should.

  7. #7
    ROG Member Array
    Join Date
    Dec 2016
    Reputation
    10
    Posts
    9

    Here is a screenshot of the "Effects Panel" for the channel configuration

    Click image for larger version. 

Name:	PeaceEffects.jpg 
Views:	11 
Size:	138.9 KB 
ID:	71033

  8. #8
    New ROGer Array
    Join Date
    Aug 2016
    Reputation
    10
    Posts
    20

    Quote Originally Posted by Mollari View Post
    Here is a screenshot of the "Effects Panel" for the channel configuration

    Click image for larger version. 

Name:	PeaceEffects.jpg 
Views:	11 
Size:	138.9 KB 
ID:	71033
    Nice, what I did is disable subwoofer for the front channels as the fronts provide enough bass as it is so I let the subwoofers work for the rear and side as they only have 20mm drivers. On games like pubg that don't support 7.1 the sides and rears just don't sound as they should. This also fixes the tinny issue people were having. I might create a new thread with a profile for pubg that I created.

  9. #9
    New ROGer Array
    Join Date
    Jan 2018
    Reputation
    10
    Posts
    3

    Could you upload a picture of your settings?

    Quote Originally Posted by XtraArrow View Post
    Nice, what I did is disable subwoofer for the front channels as the fronts provide enough bass as it is so I let the subwoofers work for the rear and side as they only have 20mm drivers. On games like pubg that don't support 7.1 the sides and rears just don't sound as they should. This also fixes the tinny issue people were having. I might create a new thread with a profile for pubg that I created.
    XtraArrow:
    I don't know if it's me who's doing something wrong, but I can't seem to have any success with the Equalizer APO software. Could you perhaps upload a picture of your equalizer settings and the effects windows? It would be greatly appreciated.

  10. #10
    New ROGer Array
    Join Date
    Aug 2016
    Reputation
    10
    Posts
    20

    Quote Originally Posted by Skofgaard View Post
    XtraArrow:
    I don't know if it's me who's doing something wrong, but I can't seem to have any success with the Equalizer APO software. Could you perhaps upload a picture of your equalizer settings and the effects windows? It would be greatly appreciated.
    I can help you mate, are you able to elaborate on what you mean when you say the software isn't working for you?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •