Page 3 of 3 FirstFirst 1 2 3
Results 21 to 23 of 23
  1. #21
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by MLGbr View Post
    I found the final solution for the Rog Spatha Mouse.

    After

    1) Updating Rog Armory
    2) Remove Rog Armory from Windows start

    I CHANGE THE USB PORT !!!

    Windows detected the mouse, did the installation, and now it works perfectly.

    Never again of problem of bad detection.

    100% solved!!!
    Which USB port was giving you issues? Front-panel?
    DId you update to Armoury 2.04.09?

  2. #22
    New ROGer Array
    Join Date
    Jan 2018
    Reputation
    10
    Posts
    15

    Cool Answers

    I'm still with Armory 2.04.07 (I have not updated it since).

    Windows had already registered the mouse on that USB port, so it was necessary to change the USB port so WIndows installed the mouse "from scratch" on the computer.

    It's a Windows 7 trick.
    When a USB device is not properly installed in a USB port (and errors or failures occur), switching the USB port will force Windows to install the hardware "from scratch" on the other port, and the problem disappears.


    I use two mouses.

    Rog Spatha in the USB 2 front
    Another vulgar mouse in rear USB ( was used, when Spatha presented problems )

    Thus, complete solution went through 3 steps:

    1) Upgrade Rog Armory ( resuscitate the mouse. Before that, it did not even work on another computer. )
    2) Remove Rog Armory 2.04.07 from start (fixes the problem of stopping detecting the mouse every 5 minutes)
    3) Replace the USB port installation (solve all random detection problems)

    Now both mouse are working, in rear USBs ports.

  3. #23
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Occasionally the front panel ports and hubs can cause problems, best to go with rear ports when troubleshooting.

    Try 2.04.09 if you run into any more issues.

Page 3 of 3 FirstFirst 1 2 3

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •