Results 1 to 4 of 4
  1. #1
    New ROGer Array OlyaAndrey's Avatar
    Join Date
    Jan 2018
    Reputation
    10
    Posts
    1

    Problem solution Fan Expert 2/AsusFanControlService

    If the error "ERROR ON THE SERVER, PROGID:" AsusFanControlService.FanControlMenedger ", it is necessary to uninstall Fan Xpert from the AI Suite II utility, restart the PC, turn off the AsusFanControlService service and delete the AsusFanControlService folder from the C: / Program Files (x86) / ASUS directory , then the AsusFanService line in the directory HKEY_LOCAL_MACHINE-> SOFTWARE-> Wow6432Node-> Asus is deleted in the registry, restart the PC and reinstall Fan Xpert from the driver disk for the motherboard or download from the Asus website.

    Last edited by OlyaAndrey; 01-26-2018 at 09:43 AM.

  2. #2
    ROG Junior Member Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    1

    This reply is from 2018. Is this still a valid way to fix this same issue in 2021? My brand new PC was working fine. I didnt notice (possibly got a windows update) but I started getting this very error. My attempts to uninstall and reinstall didnt work. Perhaps leftover crap in the registry. Not sure. My MOBO didnt comes with a driver disk, just link to the Asus site. The AI suite 3 didnt seem to have a separate fan control, just the DIG5 which I think includes the fan control.

  3. #3
    ROG Member Array
    Join Date
    Sep 2015
    Reputation
    10
    Posts
    7

    Quote Originally Posted by jetguat View Post
    This reply is from 2018. Is this still a valid way to fix this same issue in 2021? My brand new PC was working fine. I didn't notice (possibly got a windows update) but I started getting this very error. My attempts to uninstall and reinstall didn't work. Perhaps leftover crap in the registry. Not sure. My MOBO didn't comes with a driver disk, just link to the Asus site. The AI suite 3 didn't seem to have a separate fan control, just the DIG5 which I think includes the fan control.
    yeah it seems this problem came back in 2021. 2 different motherboards and CPU have the exact same problem. it's so annoying I can't even explain

  4. #4
    ROG Member Array
    Join Date
    Sep 2015
    Reputation
    10
    Posts
    7

    Quote Originally Posted by jetguat View Post
    This reply is from 2018. Is this still a valid way to fix this same issue in 2021? My brand new PC was working fine. I didnt notice (possibly got a windows update) but I started getting this very error. My attempts to uninstall and reinstall didnt work. Perhaps leftover crap in the registry. Not sure. My MOBO didnt comes with a driver disk, just link to the Asus site. The AI suite 3 didnt seem to have a separate fan control, just the DIG5 which I think includes the fan control.
    there is a workaround it that i found working(but it only fixes it temporary: so first close the ai suite from the bottom task bar(next to your time) than open task manager and look in processes for "AsusFanControlService" right click end process than you can reopen ai suite and it will work for some time till you get the silly error again

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •