Results 1 to 3 of 3
  1. #1
    ROG Member Array
    Join Date
    Feb 2014
    Reputation
    10
    Posts
    9

    G750 jh dead. power block light goes off if plugged.

    Went black in the middle of the game (on the table). Tried to restart and after some seconds died completely. No lights, no nothing. Never dropped or damaged. Didn't install any hardware lately. Power adapter shows 19,56v and drops to 0,2 v if plugged to computer. Powerjack seems to seats properly (opened key board and lifted powerswitch plate but not MB yet) Any ideas what it is wrong?
    Last edited by numanRC; 02-11-2018 at 06:25 AM.

  2. #2
    ROG Guru: Yellow Belt Array
    Join Date
    Nov 2014
    Reputation
    13
    Posts
    238

    Some shortcut. -> power brick light goes off when there is a shortcut.
    To be 100% sure it is NOT power brick.. Try power brick at different laptop, try different powerbrick.
    Then try to remove battery and test if you can use only power brick... if yes -> you have shortcut inside the battery... If still no go, shortcut can be anywhere inside the laptop.

  3. #3
    Rog Freak Array ll_r1d0_ll PC Specs
    ll_r1d0_ll PC Specs
    Laptop (Model)Asus G73sw
    MotherboardAsusTek Computer Inc.
    Processori7 2630m 2.0
    Memory (part number)10gb 1333 Kingston 4-4-2-0
    Graphics Card #1Nvidia Gtx 460m 1Gb 128bit
    Monitor1600x900 17'3
    Storage #1500gb Seagate 7200rpm
    Storage #2640gb WD 5400rpm
    CPU CoolerStock
    Power Supply120w Asus Oem AC adapter
    OS Windows 7 64bit

    Join Date
    May 2015
    Reputation
    10
    Posts
    43

    Quote Originally Posted by numanRC View Post
    Went black in the middle of the game (on the table). Tried to restart and after some seconds died completely. No lights, no nothing. Never dropped or damaged. Didn't install any hardware lately. Power adapter shows 19,56v and drops to 0,2 v if plugged to computer. Powerjack seems to seats properly (opened key board and lifted powerswitch plate but not MB yet) Any ideas what it is wrong?
    im pretty sure your GPU is dead..just remove it and your laptop wll turn on again (but without display) as i have experienced this on my asus g73jh and alienware m17x r4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •