Results 1 to 5 of 5
  1. #1
    ROG Enthusiast Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    27

    Unhappy Asus G750JW - Flickering Screen (Loose Contact?)

    Hey guys,

    for like a month or so I am sometimes having the issue of a flickering screen (display wildly going blue/black) and also sometimes the display doesnt work at all. This problem seems to be a hardware issue, as this is present in boot aswell. I guess it is a loose contact or - if even worse - my graphics card is broken.

    Has anyone else experienced such issues?

    Cheers x

  2. #2
    ROG Member Array
    Join Date
    Sep 2012
    Reputation
    10
    Posts
    24

    There is a multi conductor cable with connectors between the mb and the screen. You could have just a broken wire on it after a lot of use opening/closing the lid. I replaced the screen on my g751jy and it looked easily damaged the way they snaked it through by the hinge. Connector could also be a bit loose on one end. Hoping for the best of course. Its not difficult to get to but takes a little patience and they are available on ebay.
    it has about 20 wires like a ribbon cable but individual wires in this case.
    gl and I hope thats all it is and not anything non replacable card related.
    Try an external monitor to test if its the card.

  3. #3
    ROG Enthusiast Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    27

    Quote Originally Posted by scrufy View Post
    There is a multi conductor cable with connectors between the mb and the screen. You could have just a broken wire on it after a lot of use opening/closing the lid. I replaced the screen on my g751jy and it looked easily damaged the way they snaked it through by the hinge. Connector could also be a bit loose on one end. Hoping for the best of course. Its not difficult to get to but takes a little patience and they are available on ebay.
    it has about 20 wires like a ribbon cable but individual wires in this case.
    gl and I hope thats all it is and not anything non replacable card related.
    Try an external monitor to test if its the card.
    First off: Thank you!

    On external monitor, I havent had any issues so far... But sometimes, the whole system freezes (so far only when I play Heroes of the Storm). What do you think?

  4. #4
    ROG Enthusiast Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    27

    So yeah.. today my G750JW screen was black again, so I tried to re-plug the cable on the display and on the mainboard. Didn't help. I will try getting a replacement cable and report back if that helped.

    Peace x

  5. #5
    ROG Enthusiast Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    27

    Little update: I found out that I always plugged out the webcam cable and not the screen cable. So I double checked both ends of the screen connection and the screen doesn't turn on anymore. External monitor works so far.

    Will order a replacement cable and report back if that helped.

    EDIT: So I plugged in a HDMI cable and suddenly, my screen went on again. --I found out that if I tap at the place where the screen connector to the mainboard sits under, the screen goes on. Seems like a loose contact of the connection to the mainboard itself.
    Last edited by fschoenfeldt; 03-12-2018 at 06:32 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •