Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    3

    Question ROG STRIX X470-F Gaming Stuck on Bios Press del or f2

    Hi,
    really hope someone can give me a clue what is up with this board / setup.
    Upgrading PC so i bought this board with Ryzen 2700 / 16gb Corsair RGB

    Boots fine fine a single beep but then hangs on a Bios screen that asks me to Press Del to enter bios or f2.

    It wont accept any key input ? tried 2 keyboards but exactly the same.
    Keyboard is working as ctrl-alt-del produces a reboot but comes back to exactly the same place.

    All i have connected up is board / mem / vid and keyboard.

    absolutely not a clue and a tad miffed , not exactly scrimped :-((

    thx
    Paul

  2. #2
    New ROGer Array RedSector73 PC Specs
    RedSector73 PC Specs
    MotherboardROG CROSSHAIR VIII HERO (WI-FI)
    ProcessorAMD Ryzen 9 3900X 12-Core Processor
    Memory (part number)PVR416G413C9K @3800 16-15-15-30 CR1 or @3600 14-15-14-28 CR1
    Graphics Card #1Gigabyte Aorus RTX 2080 Ti Xtreme WaterForce (GV-N208TAORUSX W-11GC)
    MonitorAsus ROG Swift PG348Q
    Storage #1ADATA SX8200PNP 1TB
    Storage #22 x Samsung SSD 840 EVO 250GB
    CPU CoolerCoolermaster Liquid Pro Master 360
    CaseEVGA DG-87 Gunmetal Grey Gaming Case
    Power SupplyEVGA SuperNOVA G2 750W Gold Power
    Keyboard Corsair K95 RGB Platinum
    Mouse Corsair Gaming Sabre RGB Gaming Mouse
    Headset ARCTIS Pro Wireless
    Mouse Pad Cooler Master MP750 RGB Cloth Gaming Mouse Pad Extra Large
    OS Windows 10 64bit Pro
    Network RouterRT-AC87U

    Join Date
    Apr 2018
    Reputation
    40
    Posts
    383

    Make sure (from the CPU) the RAM is in slots 2 & 4.

  3. #3
    ROG Enthusiast Array Filters PC Specs
    Filters PC Specs
    MotherboardAsus Rog X470-F
    ProcessorRyzen 5 3600X
    Memory (part number)TridentZ F4-3200C14-8GTZ
    Graphics Card #1Msi Gtx 1070 Gaming 8g
    Storage #1Samsung Evo850
    Storage #2Crucial MX300 M.2
    CPU CoolerCustom Water loop EK
    CaseFractal Design R5
    Power SupplyEvga 650 P2
    OS Win10Pro

    Join Date
    Jan 2018
    Reputation
    10
    Posts
    63

    try also remove battery for like 10 minute
    also try disconnect all unnecessary just to be sure nothing interfer

  4. #4
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    3

    Quote Originally Posted by RedSector73 View Post
    Make sure (from the CPU) the RAM is in slots 2 & 4.
    it is bud. also just ried it with 1 stick. Its going to be sent back but thx for the reply :-)

  5. #5
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    3

    Quote Originally Posted by Filters View Post
    try also remove battery for like 10 minute
    also try disconnect all unnecessary just to be sure nothing interfer
    Done and only things connected are bare min to get a boot up. Ive done a usb boot stick with latest bios on but it even ignores that. Boards going back but thx for the reply :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •