Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1
    New ROGer Array
    Join Date
    Dec 2016
    Reputation
    10
    Posts
    1

    Exclamation Bluetooth not working on Rampage V Edition 10

    I've tried updating the driver software, installing and reinstalling:

    Bluetooth Driver Package V12.0.1.650 (DriverVersion 12.0.1.653) for Windows 10 64bit.(WHQL)

    to no avail. The strange thing is that the Bluetooth can sometimes detect a device, but it pops up as Unknown and is unable to ever pair with the device.

    Has anyone experienced a similar problem, or have any suggested fixes?
    Last edited by therealstevezissou; 01-01-2017 at 03:15 AM.

  2. #2
    ROG Guru: Brown Belt Array Brighttail PC Specs
    Brighttail PC Specs
    Laptop (Model)Asus G751JT
    MotherboardAsus x299 Rampage VI Extreme
    ProcessorIntel i9-7900x
    Memory (part number)Corsair Dominator Platinum SE 3200Mhz 4x8
    Graphics Card #1MSI GTX 1080TI
    MonitorAcer XB321HK (4k,IPS,G-sync)
    Storage #1Intel 900p (Boot) 2xSM961 (RAID 0) Games
    Storage #2Samsung 850 Pro 512GB - WD Black 4TB
    CPU CoolerCustom Water Cool
    CasePhanteks Enthoo Elite
    Power SupplyCorsair AX 1200i
    Keyboard Corsair Platinum 95
    Mouse Asus SPATHA
    Mouse Pad Corsair MM800
    Headset/Speakers Kanyo Y5
    OS Windows 10 64 bit
    Accessory #1 2 x Alphacool Full Copper Radiator 420mm/280mm
    Accessory #2 Monsoon MMRS reservoir w/ 2 x D5 Vario Pump
    Accessory #3 Monsoon Free Center Compression Fittings

    Join Date
    Sep 2014
    Reputation
    33
    Posts
    1,336

    Several threads on this. It is a known issue, especially with and since Windows 10 Anniversary Update. We all know about it, we've complained about it, some have no issue but many do. Asus.. doesn't seem to acknowledge or care. I got a bluetooth dongle. This works great!

    Seriously if you want to go back over older threads do a google search on Asus rampage edition 10 Bluetooth not working.
    Panteks Enthoo Elite / Asus x299 Rampage VI Extreme / Intel I9-7900X / Corsair Dominator RGB 3200MHz
    MSI GTX 1080 TI / 2x Intel 900p / Samsung 970 Pro 512GB
    Samsung 850 PRO 512GB / Western Digital Gold 8TB HD
    Corsair AX 1200i / Corsair Platinum K95 / Asus Chakram
    Acer XB321HK 4k, IPS, G-sync Monitor / Water Cooled / Asus G571JT Laptop

  3. #3
    ROG Enthusiast Array Godofmosquitoes PC Specs
    Godofmosquitoes PC Specs
    Laptop (Model)Dell XPS 15 9570 8750H 4K, 16GB, 512GB
    MotherboardRVE10
    Processor6950X@4GHz 1.2V
    Memory (part number)F4-3200C14Q-64GVK
    Graphics Card #1GTX 1080 Ti
    Graphics Card #2GTX 1080 Ti
    Sound CardSound BlasterX AE-5
    MonitorASUS PG43UQ
    Storage #1Samsung 960 Pro 1TB
    Storage #21xCrucial MX300 2TB, 1xSeagate Enterprise Capacity 4TB, 3xSeagate Archive 8TB
    CPU CoolerThermalright Le Grande Macho RT
    CaseSilverstone FT02
    Power SupplyCorsair AX1600i
    Keyboard Corsair K70 RGB MX Silent
    Mouse Logitech G502
    Headset Sennheiser GSP 500
    Headset/Speakers Bowers & Wilkins MM-1
    OS Windows 10 Pro x64
    Network RouterASUS RT-AC88U

    Join Date
    Dec 2014
    Reputation
    10
    Posts
    64

    Quote Originally Posted by Brighttail View Post
    Several threads on this. It is a known issue, especially with and since Windows 10 Anniversary Update. We all know about it, we've complained about it, some have no issue but many do. Asus.. doesn't seem to acknowledge or care. I got a bluetooth dongle. This works great!

    Seriously if you want to go back over older threads do a google search on Asus rampage edition 10 Bluetooth not working.
    This is not an RVE10 or ASUS specific issue. This is a Broadcom issue. As in, the provider of the WiFi and Bluetooth chipset and driver used on the motherboard. If the WiFi card wasn't hidden behind the protective cover, a solution might be to simply exchange it for, say, an Intel chip.

  4. #4
    ROG Guru: White Belt Array Catalonia PC Specs
    Catalonia PC Specs
    MotherboardAsus Rampage V Eddition 10
    Processori7 6850k Broadwell-e @ 4.3GHz
    Memory (part number)G.Skill Trident Z DDR4 3200MHz CL14 32GB 4x8GB
    Graphics Card #1Asus Strix 1080 Ti OC
    MonitorAsus ROG Swift PG279Q 165Hz G-Sync IPS
    Storage #1Samsung SM961 M.2 512GB NVME
    Storage #23TB WD RED
    CPU CoolerCorsair H150i PRO
    CaseCorsair 780T Black
    Power SupplyCorsair AX1600i
    Keyboard Corsair K95 Platinum
    Mouse Logitech G903
    Headset Audio Technica DSR9BT
    Mouse Pad Corsair MM800 Polaris RGB
    OS W10
    Network RouterAsus GT-AC5300

    Join Date
    Sep 2015
    Reputation
    10
    Posts
    92

    Quote Originally Posted by Godofmosquitoes View Post
    This is not an RVE10 or ASUS specific issue. This is a Broadcom issue. As in, the provider of the WiFi and Bluetooth chipset and driver used on the motherboard. If the WiFi card wasn't hidden behind the protective cover, a solution might be to simply exchange it for, say, an Intel chip.
    Wrong.

    Asus is building a product, and if the product doesn't work, Asus is the responsible. We've been having issues with this for way too long, we've got nothing, not a statement, not even a simple post saying (we're working on it) Nothing.

    it is an Asus fault by ALL means. No matter who is the primary provider of the chip that actually have issues.

    As said before, I ended up buying a USB dongle in Amazon. But, seriously guys...

  5. #5
    ROG Guru: Brown Belt Array Brighttail PC Specs
    Brighttail PC Specs
    Laptop (Model)Asus G751JT
    MotherboardAsus x299 Rampage VI Extreme
    ProcessorIntel i9-7900x
    Memory (part number)Corsair Dominator Platinum SE 3200Mhz 4x8
    Graphics Card #1MSI GTX 1080TI
    MonitorAcer XB321HK (4k,IPS,G-sync)
    Storage #1Intel 900p (Boot) 2xSM961 (RAID 0) Games
    Storage #2Samsung 850 Pro 512GB - WD Black 4TB
    CPU CoolerCustom Water Cool
    CasePhanteks Enthoo Elite
    Power SupplyCorsair AX 1200i
    Keyboard Corsair Platinum 95
    Mouse Asus SPATHA
    Mouse Pad Corsair MM800
    Headset/Speakers Kanyo Y5
    OS Windows 10 64 bit
    Accessory #1 2 x Alphacool Full Copper Radiator 420mm/280mm
    Accessory #2 Monsoon MMRS reservoir w/ 2 x D5 Vario Pump
    Accessory #3 Monsoon Free Center Compression Fittings

    Join Date
    Sep 2014
    Reputation
    33
    Posts
    1,336

    Quote Originally Posted by Godofmosquitoes View Post
    This is not an RVE10 or ASUS specific issue. This is a Broadcom issue. As in, the provider of the WiFi and Bluetooth chipset and driver used on the motherboard. If the WiFi card wasn't hidden behind the protective cover, a solution might be to simply exchange it for, say, an Intel chip.
    I would be okay with this explanation if:
    1. All their techs knew this answer when I called. Most have no idea that this is even an issue.
    2. If I saw other motherboards with bluetooth having similar issues. I've done some checking and if it was a full Broadcom issue, then I think it is safe to assume that MANY MANY more motherboards of all manufacturers would be having this issue. I'm just not seeing that.
    3. Considering that the R5E and the R5E10 use pretty much the same WIFI, one would think if it was a Broadcom issue there would be an issue with BOTH motherboards, but my R5E in my other system has ZERO issues with Bluetooth and the Anniversary update, nor does my z97 Formula.

    It is becomes of this I believe that this is a BIOS issue with Asus and the R5E10 board.
    Panteks Enthoo Elite / Asus x299 Rampage VI Extreme / Intel I9-7900X / Corsair Dominator RGB 3200MHz
    MSI GTX 1080 TI / 2x Intel 900p / Samsung 970 Pro 512GB
    Samsung 850 PRO 512GB / Western Digital Gold 8TB HD
    Corsair AX 1200i / Corsair Platinum K95 / Asus Chakram
    Acer XB321HK 4k, IPS, G-sync Monitor / Water Cooled / Asus G571JT Laptop

  6. #6
    ROG Enthusiast Array Godofmosquitoes PC Specs
    Godofmosquitoes PC Specs
    Laptop (Model)Dell XPS 15 9570 8750H 4K, 16GB, 512GB
    MotherboardRVE10
    Processor6950X@4GHz 1.2V
    Memory (part number)F4-3200C14Q-64GVK
    Graphics Card #1GTX 1080 Ti
    Graphics Card #2GTX 1080 Ti
    Sound CardSound BlasterX AE-5
    MonitorASUS PG43UQ
    Storage #1Samsung 960 Pro 1TB
    Storage #21xCrucial MX300 2TB, 1xSeagate Enterprise Capacity 4TB, 3xSeagate Archive 8TB
    CPU CoolerThermalright Le Grande Macho RT
    CaseSilverstone FT02
    Power SupplyCorsair AX1600i
    Keyboard Corsair K70 RGB MX Silent
    Mouse Logitech G502
    Headset Sennheiser GSP 500
    Headset/Speakers Bowers & Wilkins MM-1
    OS Windows 10 Pro x64
    Network RouterASUS RT-AC88U

    Join Date
    Dec 2014
    Reputation
    10
    Posts
    64

    Quote Originally Posted by Catalonia View Post
    Wrong.

    Asus is building a product, and if the product doesn't work, Asus is the responsible. We've been having issues with this for way too long, we've got nothing, not a statement, not even a simple post saying (we're working on it) Nothing.

    it is an Asus fault by ALL means. No matter who is the primary provider of the chip that actually have issues.

    As said before, I ended up buying a USB dongle in Amazon. But, seriously guys...
    I'm sorry, your statement makes no sense. If ASUS produces a graphics card by nVidia or AMD, and either provides a driver, which makes some new game unplayable, there ain't nothing ASUS can do about it either.

    This situation is the same. Broadcom have provided a WiFi/Bluetooth chipset with drivers which apparently have issues working properly. Complaining to ASUS won't help. Just as only nVidia and AMD would be able to develop a new driver, making the new game playable, only Broadcom can provide a working driver for the WiFi/Bluetooth chipset. There ain't nothing ASUS can do. Nothing. Nada.

    Say, have you even attempted to acquire a new driver from Broadcom themselves? Or do you also sit on ASUS' site, and wait for them to post a new driver for your GeForce/Radeon card, rather than going straight to nVidia/AMD? I happen to know there are newer drivers available for the chipset, than those posted on ASUS' site. Try something like station-drivers.com - they usually have the latest of everything posted.

  7. #7
    ROG Enthusiast Array Godofmosquitoes PC Specs
    Godofmosquitoes PC Specs
    Laptop (Model)Dell XPS 15 9570 8750H 4K, 16GB, 512GB
    MotherboardRVE10
    Processor6950X@4GHz 1.2V
    Memory (part number)F4-3200C14Q-64GVK
    Graphics Card #1GTX 1080 Ti
    Graphics Card #2GTX 1080 Ti
    Sound CardSound BlasterX AE-5
    MonitorASUS PG43UQ
    Storage #1Samsung 960 Pro 1TB
    Storage #21xCrucial MX300 2TB, 1xSeagate Enterprise Capacity 4TB, 3xSeagate Archive 8TB
    CPU CoolerThermalright Le Grande Macho RT
    CaseSilverstone FT02
    Power SupplyCorsair AX1600i
    Keyboard Corsair K70 RGB MX Silent
    Mouse Logitech G502
    Headset Sennheiser GSP 500
    Headset/Speakers Bowers & Wilkins MM-1
    OS Windows 10 Pro x64
    Network RouterASUS RT-AC88U

    Join Date
    Dec 2014
    Reputation
    10
    Posts
    64

    Quote Originally Posted by Brighttail View Post
    I would be okay with this explanation if:
    1. All their techs knew this answer when I called. Most have no idea that this is even an issue.
    2. If I saw other motherboards with bluetooth having similar issues. I've done some checking and if it was a full Broadcom issue, then I think it is safe to assume that MANY MANY more motherboards of all manufacturers would be having this issue. I'm just not seeing that.
    3. Considering that the R5E and the R5E10 use pretty much the same WIFI, one would think if it was a Broadcom issue there would be an issue with BOTH motherboards, but my R5E in my other system has ZERO issues with Bluetooth and the Anniversary update, nor does my z97 Formula.

    It is becomes of this I believe that this is a BIOS issue with Asus and the R5E10 board.
    It is a Broadcom issue. It varies from chipset model to chipset model, which has and which hasn't got issues. Currently for example, the Bluetooth of my HTC Vive isn't working either. Same issue as you're describing. And they use, gasp, Broadcom for their Bluetooth chipset.

  8. #8
    ROG Enthusiast Array Godofmosquitoes PC Specs
    Godofmosquitoes PC Specs
    Laptop (Model)Dell XPS 15 9570 8750H 4K, 16GB, 512GB
    MotherboardRVE10
    Processor6950X@4GHz 1.2V
    Memory (part number)F4-3200C14Q-64GVK
    Graphics Card #1GTX 1080 Ti
    Graphics Card #2GTX 1080 Ti
    Sound CardSound BlasterX AE-5
    MonitorASUS PG43UQ
    Storage #1Samsung 960 Pro 1TB
    Storage #21xCrucial MX300 2TB, 1xSeagate Enterprise Capacity 4TB, 3xSeagate Archive 8TB
    CPU CoolerThermalright Le Grande Macho RT
    CaseSilverstone FT02
    Power SupplyCorsair AX1600i
    Keyboard Corsair K70 RGB MX Silent
    Mouse Logitech G502
    Headset Sennheiser GSP 500
    Headset/Speakers Bowers & Wilkins MM-1
    OS Windows 10 Pro x64
    Network RouterASUS RT-AC88U

    Join Date
    Dec 2014
    Reputation
    10
    Posts
    64

    As for Broadcom Wifi/Bluetooth on the RVE10.

    This Bluetooth driver: http://station-drivers.com/index.php...d=2130&lang=fr

    And this WiFi driver: http://station-drivers.com/index.php...d=1985&lang=fr

    Makes both work flawlessly here.

    I know, I know. Naughty me, deep-linking and everything.

  9. #9
    ROG Enthusiast Array armin_maleki PC Specs
    armin_maleki PC Specs
    MotherboardRampage v10
    ProcessorCor i7 6850K
    Memory (part number)Trident Z
    Graphics Card #1Rog Strix 1070
    Storage #1Evo 960
    CPU CoolerEK-XLC Predator 360
    Casecorsair 760t white
    Power Supplycooler master v1200 platinum
    Keyboard HyperX kingstone
    Mouse Logitech mxmaster
    Mouse Pad HyperX kingstone
    Network RouterTplink archer c9
    armin_maleki's Avatar
    Join Date
    Nov 2016
    Reputation
    10
    Posts
    54

    Quote Originally Posted by Godofmosquitoes View Post
    As for Broadcom Wifi/Bluetooth on the RVE10.

    This Bluetooth driver: http://station-drivers.com/index.php...d=2130&lang=fr

    And this WiFi driver: http://station-drivers.com/index.php...d=1985&lang=fr

    Makes both work flawlessly here.

    I know, I know. Naughty me, deep-linking and everything.
    cant work for me!

  10. #10
    ROG Enthusiast Array armin_maleki PC Specs
    armin_maleki PC Specs
    MotherboardRampage v10
    ProcessorCor i7 6850K
    Memory (part number)Trident Z
    Graphics Card #1Rog Strix 1070
    Storage #1Evo 960
    CPU CoolerEK-XLC Predator 360
    Casecorsair 760t white
    Power Supplycooler master v1200 platinum
    Keyboard HyperX kingstone
    Mouse Logitech mxmaster
    Mouse Pad HyperX kingstone
    Network RouterTplink archer c9
    armin_maleki's Avatar
    Join Date
    Nov 2016
    Reputation
    10
    Posts
    54

    i see this on rampage v10 support site now
    Click image for larger version. 

Name:	1-11-2017 10-29-56 PM.jpg 
Views:	0 
Size:	39.0 KB 
ID:	61802

    new bios 1502 just in windows 7 X64?
    is it true?

Page 1 of 3 1 2 3 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •