Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    2

    Z97-PRO AI SUite 3 and UASP?

    Hello ALL:
    I am posting here because you all give the MOST help!
    I just bought Sabrent SATA III to USB 3 docks and they support UASP. However, my AI Suite says I need to reinstall USB 3.0 Boost. I have 2 issues here. I use 64 bit Windows 10 Pro (not CU) and MY AI Suite 3 causes issues so I had it disabled. I enabled it anyway. but USB Boost did not install.
    Here is what I wonder...

    My AI SUITE 3 is Version 1.00.79 and was told to get the latest which I believe is 1.01.02
    I was also told to get a new AS Media USB 3 driver. Mine is 1.16.15.0 and the new one is 1.16.35.1

    My BIOS is still 2205.

    So, can I just install the Updated ASMedia USB 3 driver first, then use Control Panel to remove AI Suite 3 and then reinstall the new AI Suite 3?
    Will UASP then be supported? Since I do not have the Docks yet, will Device manager show that UASP is enabled as I do not see it now and I assume along with the software I do not need any BIOS tweaks.

    I hope this is not too much to ask but UASP seems to be a dead end when I ask on any other forum and I assume this site will be able to help. I hope that this is the correct section as it is mainly ASUS Software I have issues with.

  2. #2
    New ROGer Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    2

    WOW, is my MoBo so old that no one is using UASP?
    Anyway, to remove and reinstall AI Suite III I was told to...use Control Panel, go to start menu and use the built in asus uninstall and when I reinstall click asussetup. Others say just use setup. This should not be so hard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •